当前位置: 代码迷 >> 综合 >> PTA 1004 Counting Leaves(树的深搜)
  详细解决方案

PTA 1004 Counting Leaves(树的深搜)

热度:29   发布时间:2023-11-22 05:10:16.0

1004 Counting Leaves (30 分)

题目

            **1004 Counting Leaves (30 分)**

A family hierarchy is usually presented by a pedigree tree. Your job is to count those family members who have no child.

Input Specification:
Each input file contains one test case. Each case starts with a line containing 0<N<100, the number of nodes in a tree, and M (<N), the number of non-leaf nodes. Then M lines follow, each in the format:

ID K ID[1] ID[2] … ID[K]
where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID’s of its children. For the sake of simplicity, let us fix the root ID to be 01.

The input ends with N being 0. That case must NOT be processed.

Output Specification:
For each test case, you are supposed to count those family members who have no child for every seniority level starting from the root. The numbers must be printed in a line, separated by a space, and there must be no extra space at the end of each line.

The sample case represents a tree with only 2 nodes, where 01 is the root and 02 is its only child. Hence on the root 01 level, there is 0 leaf node; and on the next level, there is 1 leaf node. Then we should output 0 1 in a line.

Sample Input:
2 1
01 1 02
结尾无空行
Sample Output:
0 1
结尾无空行
代码长度限制
16 KB
时间限制
400 ms
内存限制
64 MB

题意:

给你一棵树,顺序输出每一层的叶子数目

思路:

用邻接表来存储树,通过dfs回溯深搜来进行树的搜索来寻找所有叶子及其所在层数

代码:

#include<bits/stdc++.h>using namespace std;int head[110],e[210],ne[210],idx;
int ans[110];
int q = 0;void add(int a , int b){
    e[idx] = b,ne[idx] = head[a],head[a] = idx++;
}void dfs(int a , int cnt)
{
    q = max(q,cnt);if(head[a] == -1) ans[cnt]++;else{
    for(int i = head[a] ; i != -1 ; i = ne[i]){
    dfs(e[i],cnt+1);}}
}int main()
{
    int n,m;cin>>n>>m;memset(head,-1,sizeof head);for(int i = 0 ; i < m ; i ++){
    int a,k;cin>>a>>k;for(int j = 0 ; j < k ; j ++){
    int b;cin>>b;add(a,b); }	 }dfs(1,0);
// cout<<q<<endl;for(int i = 0 ; i < q ; i ++) cout<<ans[i]<<" ";cout<<ans[q];return 0;}