当前位置: 代码迷 >> 综合 >> Power Strings(求最小循环节)
  详细解决方案

Power Strings(求最小循环节)

热度:39   发布时间:2023-11-22 01:49:35.0

题目链接poj2406

Given two strings a and b we define ab to be their concatenation. For example, if a = “abc” and b = “def” then ab = “abcdef”. If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = “” (the empty string) and a^(n+1) = a*(a^n).

Input

Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.

Output

For each s you should print the largest n such that s = a^n for some string a.
Sample Input
abcd
aaaa
ababab
.

Sample Output

1
4
3

Hint

This problem has huge input, use scanf instead of cin to avoid time limit exceed.

求最小循环节可此参考文章
如果len可以被len - next[len]整除,则表明字符串S可以完全由循环节循环组成,循环周期T=len/L。

#include<iostream>
#include<algorithm>
#include<cstring>
#include<cstdio>
#define N 2000000
using namespace std;
char str[N];
int nextt[N];
void getnext(char *s,int slen)
{
    nextt[0]=0;nextt[1]=0;for(int i=1;i<slen;i++){
    int j=nextt[i];while(j&&s[i]!=s[j]) j=nextt[j];nextt[i+1] = (s[i]==s[j])?j+1:0;}
}int main()
{
    while(1){
    memset(nextt,0,sizeof(nextt));scanf("%s",&str);if(str[0]=='.') break;int slen =  strlen(str);getnext(str,slen);int k = slen - nextt[slen];if(slen%k==0) cout<<slen/k<<endl;else cout<<1<<endl;}}
  相关解决方案