当前位置: 代码迷 >> 综合 >> hdu 1532 最基础的求网络最大流问题
  详细解决方案

hdu 1532 最基础的求网络最大流问题

热度:92   发布时间:2023-11-18 03:43:26.0

题目链接点击打开链接

Drainage Ditches

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 19045    Accepted Submission(s): 9084


Problem Description
Every time it rains on Farmer John's fields, a pond forms over Bessie's favorite clover patch. This means that the clover is covered by water for awhile and takes quite a long time to regrow. Thus, Farmer John has built a set of drainage ditches so that Bessie's clover patch is never covered in water. Instead, the water is drained to a nearby stream. Being an ace engineer, Farmer John has also installed regulators at the beginning of each ditch, so he can control at what rate water flows into that ditch. 
Farmer John knows not only how many gallons of water each ditch can transport per minute but also the exact layout of the ditches, which feed out of the pond and into each other and stream in a potentially complex network. 
Given all this information, determine the maximum rate at which water can be transported out of the pond and into the stream. For any given ditch, water flows in only one direction, but there might be a way that water can flow in a circle. 

Input
The input includes several cases. For each case, the first line contains two space-separated integers, N (0 <= N <= 200) and M (2 <= M <= 200). N is the number of ditches that Farmer John has dug. M is the number of intersections points for those ditches. Intersection 1 is the pond. Intersection point M is the stream. Each of the following N lines contains three integers, Si, Ei, and Ci. Si and Ei (1 <= Si, Ei <= M) designate the intersections between which this ditch flows. Water will flow through this ditch from Si to Ei. Ci (0 <= Ci <= 10,000,000) is the maximum rate at which water will flow through the ditch.

Output
For each case, output a single integer, the maximum rate at which water may emptied from the pond. 

Sample Input

  
5 4 1 2 40 1 4 20 2 4 20 2 3 30 3 4 10

Sample Output

  
50

Source
USACO 93

Recommend
lwg   |   We have carefully selected several similar problems for you:  1533 3338 1569 3572 3416 

Statistic | Submit | Discuss | Note

这道题是网络最大流问题的一道入门题,数据量也不大,直接用EK算法即可

#include<iostream>
#include<queue>
#include<string.h>
using namespace std;
int n,m;
int s,e,c;
int map[201][201];//保存图
int step[201];//保存增广路径上每一点的前继节点
bool check[201];//检测该点是否用过
int ans;
bool bfs(int start,int end)//广度搜索,搜到T点结束
{memset(step,-1,sizeof(step));memset(check,false,sizeof(check));queue<int> Q;Q.push(start);check[start]=true;while(!Q.empty()){int p=Q.front();if(p==end)return true;Q.pop();for(int i=1;i<=n;i++){if(map[p][i]&&!check[i]){check[i]=true;step[i]=p;Q.push(i);}}}return false;
}
int main()
{while(cin>>m>>n){memset(map,0,sizeof(map));ans=0;for(int i=1;i<=m;i++){cin>>s>>e>>c;map[s][e]=map[s][e]+c;//可能有重边}int temp;int u;while(bfs(1,n)){temp=10000010;u=n;while(step[u]!=-1){temp=min(temp,map[step[u]][u]);u=step[u];}//找到扩充流ans=ans+temp;u=n;while(step[u]!=-1){map[step[u]][u]=map[step[u]][u]-temp;map[u][step[u]]=map[u][step[u]]+temp;u=step[u];}//构成新的残留网络}cout<<ans<<endl;}return 0;
}