当前位置: 代码迷 >> 综合 >> ZOJ Problem Set - 3640 Help Me Escape
  详细解决方案

ZOJ Problem Set - 3640 Help Me Escape

热度:61   发布时间:2023-11-18 03:36:19.0

题目链接点击打开链接
Help Me Escape

Time Limit: 2 Seconds       Memory Limit: 32768 KB

Background

    If thou doest well, shalt thou not be accepted? and if thou doest not well, sin lieth at the door. And unto thee shall be his desire, and thou shalt rule over him. 
    And Cain talked with Abel his brother: and it came to pass, when they were in the field, that Cain rose up against Abel his brother, and slew him. 
    And the LORD said unto Cain, Where is Abel thy brother? And he said, I know not: Am I my brother's keeper? 
    And he said, What hast thou done? the voice of thy brother's blood crieth unto me from the ground. 
    And now art thou cursed from the earth, which hath opened her mouth to receive thy brother's blood from thy hand; 
    When thou tillest the ground, it shall not henceforth yield unto thee her strength; a fugitive and a vagabond shalt thou be in the earth.

—— Bible Chapter 4

Now Cain is unexpectedly trapped in a cave with N paths. Due to LORD's punishment, all the paths are zigzag and dangerous. The difficulty of the ith path is ci.

Then we define f as the fighting capacity of Cain. Every day, Cain will be sent to one of the N paths randomly.

Suppose Cain is in front of the ith path. He can successfully take ti days to escape from the cave as long as his fighting capacity f is larger than ci. Otherwise, he has to keep trying day after day. However, if Cain failed to escape, his fighting capacity would increase ci as the result of actual combat. (A kindly reminder: Cain will never died.)

As for ti, we can easily draw a conclusion that ti is closely related to ci. Let's use the following function to describe their relationship:

After D days, Cain finally escapes from the cave. Please output the expectation of D.

Input

The input consists of several cases. In each case, two positive integers N and f (n ≤ 100, f ≤ 10000) are given in the first line. The second line includes N positive integers ci (ci ≤ 10000, 1 ≤ i≤ N)

Output

For each case, you should output the expectation(3 digits after the decimal point).

Sample Input

3 1
1 2 3

Sample Output

6.889

Author:  WU, Yingxin

Contest: ZOJ Monthly, August 2012


这道概率Dp可以用记忆化搜索来解决,

dp[f]代表战斗力为f时的期望,那么对于n条路径,如果c[i]<f,那么可以走出,期望为t[i]/n,

否则战斗力增加为i+c[i],递归得出dp[i+c[i]],期望为(dp[f+c[i]]+1)/n;

AC代码:

#include<iostream>
#include<string.h>
#include<cmath>
#include<stdio.h>
#define maxn 10005
using namespace std;
int n,f;
int c[maxn];
int t[maxn];
double dp[2*maxn];
double dfs(int f)
{if(dp[f]!=-1)return dp[f];double sum=0;for(int i=1;i<=n;i++){if(c[i]<f){sum=sum+(t[i]*1.0)/n;}else{sum=sum+(1.0+dfs(f+c[i])*1.0)/n;}}dp[f]=sum;return sum;
}
int main()
{while(~scanf("%d%d",&n,&f)){for(int i=0;i<=20000;i++)dp[i]=-1;for(int i=1;i<=n;i++){scanf("%d",&c[i]);t[i]=int((1.0+sqrt(5))/2*(c[i]*c[i]*1.0));}double ans=dfs(f);printf("%0.3lf\n",ans);}return 0;
}

  相关解决方案