当前位置: 代码迷 >> 综合 >> hdu 1251 统计难题 (统计前缀出现次数)
  详细解决方案

hdu 1251 统计难题 (统计前缀出现次数)

热度:93   发布时间:2023-11-06 18:06:15.0

统计难题

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 131070/65535 K (Java/Others)
Total Submission(s): 46716    Accepted Submission(s): 16581


Problem Description
Ignatius最近遇到一个难题,老师交给他很多单词(只有小写字母组成,不会有重复的单词出现),现在老师要他统计出以某个字符串为前缀的单词数量(单词本身也是自己的前缀).

Input
输入数据的第一部分是一张单词表,每行一个单词,单词的长度不超过10,它们代表的是老师交给Ignatius统计的单词,一个空行代表单词表的结束.第二部分是一连串的提问,每行一个提问,每个提问都是一个字符串.

注意:本题只有一组测试数据,处理到文件结束.

Output
对于每个提问,给出以该字符串为前缀的单词的数量.

Sample Input
   
banana band bee absolute acmba b band abc

Sample Output
   
2 3 1 0

Author
Ignatius.L
数组要开四十万才够,一直在试数据大小,疯狂re,  其实应该用malloc才对。

#include<iostream>
#include<cstring>
#include<cstdio>
#include<algorithm>
using namespace std;
const int mx = 41e4 ;
int tree[mx][26], sum[mx + 5];
int n ,tot, m;
char te[15];
void add(char * str, int rt){int x;for(int i = 0; str[i]; i++){x = str[i] - 'a';if(tree[rt][x] == 0)tree[rt][x] = ++tot;rt =  tree[rt][x];sum[rt]++;}
}
int find(char * str, int rt){int x;for(int i = 0; str[i]; i++){x = str[i] - 'a';if(tree[rt][x] == 0)return 0;           rt =  tree[rt][x];}return sum[rt];
}
int main(){//   因为只有一组数据所以不需要mem while (gets(te) && strlen(te)!= 0)add(te, 0);while(scanf("%s", te) != EOF)printf("%d\n",find(te, 0));return 0;
}





  相关解决方案