当前位置: 代码迷 >> 综合 >> BZOJ1026[windy数]
  详细解决方案

BZOJ1026[windy数]

热度:13   发布时间:2023-11-06 09:54:11.0

Description

  windy定义了一种windy数。不含前导零且相邻两个数字之差至少为2的正整数被称为windy数。 windy想知道,
在A和B之间,包括A和B,总共有多少个windy数?

Input

  包含两个整数,A B。

Output

  一个整数

Sample Input

【输入样例一】

1 10

【输入样例二】

25 50

Sample Output

【输出样例一】

9

【输出样例二】

20
HINT

【数据规模和约定】

100%的数据,满足 1 <= A <= B <= 2000000000 。

解题思路:数位DP

dp[pos][pre]表示在第pos位,前一位是pre时,满足条件的数的个数。

#include <cstdio>
#include <cmath>
#include <iostream>
#include <cstring>
using namespace std;
int a[20], dp[20][20];
int dfs( int pos, int pre, int flg){if ( pos == -1 ) return 1;if ( pre >= 0 && !flg && dp[pos][pre] != -1 ) return dp[pos][pre];int up = flg ? a[pos] : 9, ret = 0, p = 0;for ( int i = 0; i <= up; i++){if ( ( i - pre ) <= -2  || ( i - pre) >= 2){p = i;if ( i == 0 && pre == -3 ) p = pre;ret += dfs( pos-1, p, flg && ( i == up ) );}}if ( pre >= 0 && !flg ) dp[pos][pre] = ret;return ret;
}
int solve( int x ){int pos = 0;for ( ; x; a[pos++] = x % 10, x /= 10 );return dfs( pos-1, -3, 1);
}
int main(){int l, r;memset( dp, -1, sizeof(dp));scanf( "%d%d", &l, &r);printf( "%d", solve(r) - solve(l-1));
}