当前位置: 代码迷 >> 综合 >> HDU1686[Oulipo]HDU2087[剪花布条] kmp大水题
  详细解决方案

HDU1686[Oulipo]HDU2087[剪花布条] kmp大水题

热度:94   发布时间:2023-11-06 09:01:22.0

Problem Description
The French author Georges Perec (1936–1982) once wrote a book, La disparition, without the letter ‘e’. He was a member of the Oulipo group. A quote from the book:

Tout avait Pair normal, mais tout s’affirmait faux. Tout avait Fair normal, d’abord, puis surgissait l’inhumain, l’affolant. Il aurait voulu savoir où s’articulait l’association qui l’unissait au roman : stir son tapis, assaillant à tout instant son imagination, l’intuition d’un tabou, la vision d’un mal obscur, d’un quoi vacant, d’un non-dit : la vision, l’avision d’un oubli commandant tout, où s’abolissait la raison : tout avait l’air normal mais…

Perec would probably have scored high (or rather, low) in the following contest. People are asked to write a perhaps even meaningful text on some subject with as few occurrences of a given “word” as possible. Our task is to provide the jury with a program that counts these occurrences, in order to obtain a ranking of the competitors. These competitors often write very long texts with nonsense meaning; a sequence of 500,000 consecutive ‘T’s is not unusual. And they never use spaces.

So we want to quickly find out how often a word, i.e., a given string, occurs in a text. More formally: given the alphabet {‘A’, ‘B’, ‘C’, …, ‘Z’} and two finite strings over that alphabet, a word W and a text T, count the number of occurrences of W in T. All the consecutive characters of W must exactly match consecutive characters of T. Occurrences may overlap.

Input
The first line of the input file contains a single number: the number of test cases to follow. Each test case has the following format:

One line with the word W, a string over {‘A’, ‘B’, ‘C’, …, ‘Z’}, with 1 ≤ |W| ≤ 10,000 (here |W| denotes the length of the string W).
One line with the text T, a string over {‘A’, ‘B’, ‘C’, …, ‘Z’}, with |W| ≤ |T| ≤ 1,000,000.

Output
For every test case in the input file, the output should contain a single number, on a single line: the number of occurrences of the word W in the text T.

Sample Input
3
BAPC
BAPC
AZA
AZAZAZA
VERDI
AVERDXIVYERDIAN

Sample Output
1
3
0

solution: kmp_可重复

#include <cstdio>
#include <cstring>
using namespace std;
#define N 1000100
char s[N], t[N];
int nxt[N], lens, lent, tot, T;
void get_nxt(){int j=0;for( int i=1; i<lent; i++ ){while( j&&t[i]!=t[j] ) j=nxt[j];if ( t[i]==t[j] ) j++;nxt[i+1]=j;}    
}
void Kmp(){int j=0;for ( int i=0; i<lens; i++ ){while( j&&s[i]!=t[j] ) j=nxt[j];if( s[i]==t[j] ) j++;if( j==lent ) tot++, j=nxt[j];}
}
int main(){scanf( "%d", &T);while ( T-- ){tot=0;scanf("%s%s", t, s);lent=strlen(t), lens=strlen(s);get_nxt(); Kmp();printf( "%d\n", tot);}return 0;
}

Problem Description
一块花布条,里面有些图案,另有一块直接可用的小饰条,里面也有一些图案。对于给定的花布条和小饰条,计算一下能从花布条中尽可能剪出几块小饰条来呢?

Input
输入中含有一些数据,分别是成对出现的花布条和小饰条,其布条都是用可见ASCII字符表示的,可见的ASCII字符有多少个,布条的花纹也有多少种花样。花纹条和小饰条不会超过1000个字符长。如果遇见#字符,则不再进行工作。

Output
输出能从花纹布中剪出的最多小饰条个数,如果一块都没有,那就老老实实输出0,每个结果之间应换行。

Sample Input
abcde a3
aaaaaa aa
#

Sample Output
0
3

Author
qianneng

solution:kmp_不可重复

#include <cstdio>
#include <cstring>
using namespace std;
#define N 1000100
char s[N], t[N];
int nxt[N], lens, lent, tot, T;
void get_nxt(){int j=0;for( int i=1; i<lent; i++ ){while( j&&t[i]!=t[j] ) j=nxt[j];if ( t[i]==t[j] ) j++;nxt[i+1]=j;}    
}
void Kmp(){int j=0;for ( int i=0; i<lens; i++ ){while( j&&s[i]!=t[j] ) j=nxt[j];if( s[i]==t[j] ) j++;if( j==lent ) tot++, j=0;}
}
int main(){while (1){scanf("%s", s);if( s[0]=='#') break;scanf("%s", t);tot=0;lent=strlen(t), lens=strlen(s);get_nxt(); Kmp();printf( "%d\n", tot);}return 0;
}