当前位置: 代码迷 >> 综合 >> Strange Table
  详细解决方案

Strange Table

热度:99   发布时间:2023-10-14 01:36:51.0

题目

Polycarp found a rectangular table consisting of n rows and m columns. He noticed that each cell of the table has its number, obtained by the following algorithm “by columns”:

cells are numbered starting from one;
cells are numbered from left to right by columns, and inside each column from top to bottom;
number of each cell is an integer one greater than in the previous cell.
For example, if n=3 and m=5, the table will be numbered as follows:

1 2 3 4 5
6 7 8 9 10
11 12 13 14 15
However, Polycarp considers such numbering inconvenient. He likes the numbering “by rows”:

cells are numbered starting from one;
cells are numbered from top to bottom by rows, and inside each row from left to right;
number of each cell is an integer one greater than the number of the previous cell.
For example, if n=3 and m=5, then Polycarp likes the following table numbering、
Strange Table

Polycarp doesn’t have much time, so he asks you to find out what would be the cell number in the numbering “by rows”, if in the numbering “by columns” the cell has the number x?

输入格式

The first line contains a single integer t (1≤t≤104). Then t test cases follow.

Each test case consists of a single line containing three integers n, m, x (1≤n,m≤106, 1≤x≤n?m), where n and m are the number of rows and columns in the table, and x is the cell number.

Note that the numbers in some test cases do not fit into the 32-bit integer type, so you must use at least the 64-bit integer type of your programming language.

输出格式

For each test case, output the cell number in the numbering “by rows”.

样例输入

5
1 1 1
2 2 3
3 5 11
100 100 7312
1000000 1000000 1000000000000

样例输出

1
2
9
1174
1000000000000

思路

Strange Table

代码

#include<iostream>
#include<cstring>
#include<algorithm>
#define ll long long int
using namespace std;
int main()
{
    ll t;cin>>t;while(t--){
    ll a,b,c;cin>>a>>b>>c;ll x=c/a;if(c%a!=0){
    x++;}ll y=1+a*(x-1);y=c-y;ll sum=x+b*y;cout<<sum<<endl;}return 0;
}
极简版
#include<iostream>
#include<cstring>
#include<algorithm>
#define ll long long int
using namespace std;
int main(){
    ll t,a,b,c,x,y,sum;cin>>t;while(t--){
    cin>>a>>b>>c;x=c/a;if(c%a!=0) x++;y=1+a*(x-1);y=c-y;sum=x+b*y;cout<<sum<<endl;}return 0;
}

总结

思路见上图

  相关解决方案