当前位置: 代码迷 >> 综合 >> PAT甲级-1003 Emergency (25分)
  详细解决方案

PAT甲级-1003 Emergency (25分)

热度:38   发布时间:2023-09-27 00:09:08.0

点击链接PAT甲级-AC全解汇总

题目:
As an emergency rescue team leader of a city, you are given a special map of your country. The map shows several scattered cities connected by some roads. Amount of rescue teams in each city and the length of each road between any pair of cities are marked on the map. When there is an emergency call to you from some other city, your job is to lead your men to the place as quickly as possible, and at the mean time, call up as many hands on the way as possible.

Input Specification:
Each input file contains one test case. For each test case, the first line contains 4 positive integers: N (≤500) - the number of cities (and the cities are numbered from 0 to N?1), M - the number of roads, C?1?? and C?2?? - the cities that you are currently in and that you must save, respectively. The next line contains N integers, where the i-th integer is the number of rescue teams in the i-th city. Then M lines follow, each describes a road with three integers c?1?? , c?2?? and L, which are the pair of cities connected by a road and the length of that road, respectively. It is guaranteed that there exists at least one path from C?1?? to C?2?? .

Output Specification:
For each test case, print in one line two numbers: the number of different shortest paths between C?1?? and C?2?? , and the maximum amount of rescue teams you can possibly gather. All the numbers in a line must be separated by exactly one space, and there is no extra space allowed at the end of a line.

Sample Input:

5 6 0 2
1 2 1 5 3
0 1 1
0 2 2
0 3 1
1 2 1
2 4 1
3 4 1

Sample Output:

2 4

题意:
输入的是城市数量、路径数、起点、终点
每个城市的救援队数量
路径相连的两个城市 花费
目标是输出从起点到终点最短路径的条数,已经最短路径中救援队做多的数量
我的代码:

#include<bits/stdc++.h>
using namespace std;#define NUM 510
int N,M,c1,c2;
int cost[NUM][NUM];//路径长度
int mem[NUM]={
    0};//每个城市救援队的数量
int flag_ed[NUM]={
    0};//标记这个点是否访问过
int num_way=0,min_cost=9999;//最短路径
int num_max_save=0;void DFS(int start,int sum_cost,int sum_save)
{
    //出口if(start==c2){
    if(sum_cost<min_cost){
    min_cost=sum_cost;num_way=1;num_max_save=sum_save;//当前救援队数量就是最多的数量}else if(sum_cost==min_cost){
    num_way++;num_max_save=num_max_save<sum_save?sum_save:num_max_save;}return;}else{
    flag_ed[start]=true;for(int i=0;i<N;i++){
    if(flag_ed[i]==false&&cost[start][i]!=0){
    flag_ed[i]=true;sum_cost+=cost[start][i];sum_save+=mem[i];DFS(i,sum_cost,sum_save);flag_ed[i]=false;sum_cost-=cost[start][i];sum_save-=mem[i];}}}
}int main()
{
    //输入城市信息cin>>N>>M>>c1>>c2;memset(cost,0,sizeof(cost));//救援队数量for(int i=0;i<N;i++){
    cin>>mem[i];}//输入路径长度for(int i=0;i<M;i++){
    int a,b,c;cin>>a>>b>>c;cost[a][b]=c;cost[b][a]=c;}//找最短路径,并计算最大救援队数量DFS(c1,0,mem[c1]);cout<<num_way<<" "<<num_max_save;return 0;
}

思路: DFS求最短路径,并在出口处记录最短路径的条数,如果是更短路径,则要更新条数为1,救援队数量也要更新为本次,不然是最大救援队数量而不是最短路径的最大救援队数量