当前位置: 代码迷 >> 综合 >> PAT甲级-1009 Product of Polynomials (25分)
  详细解决方案

PAT甲级-1009 Product of Polynomials (25分)

热度:128   发布时间:2023-09-27 00:03:45.0

点击链接PAT甲级-AC全解汇总

题目:
This time, you are supposed to find A×B where A and B are two polynomials.

Input Specification:
Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:

K N?1?? a(?N?1)?? ?? N?2?? a?(N?2)?? ?? … N?K?? a(?N?(K))
??
??

where K is the number of nonzero terms in the polynomial, N?i?? and a?(N(?i))
??
?? (i=1,2,?,K) are the exponents and coefficients, respectively. It is given that 1≤K≤10,0≤N?K?? <?<N?2?? <N?1?? ≤1000.

Output Specification:
For each test case you should output the product of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate up to 1 decimal place.

Sample Input:
2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output:
3 3 3.6 2 6.0 1 1.6
题意:
跟PAT甲级1002的输入一样,不过1002是求和,这是求两个多项式的乘积

注意: 乘积的话指数最高可能有2000,数组要开到2000+才行

我的代码:

#include<bits/stdc++.h>
using namespace std;int main()
{
    vector<pair<int,double> >exp_ploy;int N;cin>>N;for(int i=0;i<N;i++){
    int exp;double ploy;cin>>exp>>ploy;exp_ploy.push_back(pair<int,double>(exp,ploy));}double res[2020]={
    0};cin>>N;for(int i=0;i<N;i++){
    int exp;double ploy;cin>>exp>>ploy;for(auto it:exp_ploy){
    int t_exp=it.first+exp;double t_ploy=it.second*ploy;res[t_exp]+=t_ploy;}}int cnt=0;for(int i=2000;i>=0;i--){
    if(res[i]!=0){
    cnt++;}}cout<<cnt;for(int i=2000;i>=0;i--){
    if(res[i]!=0){
    printf(" %d %.1f",i,res[i]);}}return 0;
}
  相关解决方案