当前位置: 代码迷 >> 综合 >> PAT甲级-1015 Reversible Primes (20分)
  详细解决方案

PAT甲级-1015 Reversible Primes (20分)

热度:67   发布时间:2023-09-26 23:57:35.0

点击链接PAT甲级-AC全解汇总

题目:
A reversible prime in any number system is a prime whose “reverse” in that number system is also a prime. For example in the decimal system 73 is a reversible prime because its reverse 37 is also a prime.

Now given any two positive integers N (<10?5?? ) and D (1<D≤10), you are supposed to tell if N is a reversible prime with radix D.

Input Specification:
The input file consists of several test cases. Each case occupies a line which contains two integers N and D. The input is finished by a negative N.

Output Specification:
For each test case, print in one line Yes if N is a reversible prime with radix D, or No if not.

Sample Input:

73 10
23 2
23 10
-2

Sample Output:

Yes
Yes
No

题意:
一行输入两个数字ab,判断a本身是不是素数,a经过b进制转换后逆序再转换回来后,是不是素数,如果都是素数则输出yes,否则no

我的代码:

#include<bits/stdc++.h>
using namespace std;bool is_prime(int num)
{
    if(num==0||num==1)return false;for(int i=2;i<=sqrt(num);i++)if(num%i==0)return false;return true;
}
int main()
{
    int num,radix;cin>>num;while(num>=0){
    cin>>radix;if(!is_prime(num))cout<<"No"<<endl;else{
    //转成radix进制,同时逆序string str;while(num){
    str+=num%radix+'0';num/=radix;}//转成intint ans=0;for(int i=0;i<str.length();i++){
    ans=ans*radix+(str[i]-'0');}//判断素数if(is_prime(ans))cout<<"Yes"<<endl;else cout<<"No"<<endl;}cin>>num;}return 0;
}