当前位置: 代码迷 >> 综合 >> PAT甲级-1031 Hello World for U (20分)【推荐!!!】
  详细解决方案

PAT甲级-1031 Hello World for U (20分)【推荐!!!】

热度:70   发布时间:2023-09-26 23:41:37.0

点击链接PAT甲级-AC全解汇总

题目:
Given any string of N (≥5) characters, you are asked to form the characters into the shape of U. For example, helloworld can be printed as:

h  d
e  l
l  r
lowo

That is, the characters must be printed in the original order, starting top-down from the left vertical line with n?1?? characters, then left to right along the bottom line with n?2?? characters, and finally bottom-up along the vertical line with n?3?? characters. And more, we would like U to be as squared as possible – that is, it must be satisfied that n?1?? =n?3?? =max { k | k≤n?2?? for all 3≤n?2?? ≤N } with n?1?? +n?2?? +n?3?? ?2=N.

Input Specification:
Each input file contains one test case. Each case contains one string with no less than 5 and no more than 80 characters in a line. The string contains no white space.

Output Specification:
For each test case, print the input string in the shape of U as specified in the description.

Sample Input:

helloworld!

Sample Output:

h   !
e   d
l   l
lowor

题意:
输入一串字符串,把他按照U型输出,要求是竖着的高度不超过水平的宽度。

我的思路:
题目中的k是竖着的高度,最低下一行也算(所以k=4,n2=5),我这里方便计算,k是去掉最下面一行的高度,所以k=3,n2=5
经过数学计算,很容易得出对于长度N,K应该是(N-1)/3,剩下的给n2;
所以:

k = (N - 1) / 3;
n2 = N - 2 * k;

知道竖着有k个 横着有n2个,那就一行行输出好了
竖着的部分第i行:就是正数和倒数第i个字符;
横着的部分,就是正好从k开始,共有n2个字符;
这就是为什么我算 k 的时候不算最后一行的原因!

我的代码:

#include<bits/stdc++.h>
using namespace std;int main()
{
    string str;cin>>str;int N=str.length();int k=(N-1)/3;int n2=N-2*k;string blank(n2-2,' ');for(int i=0;i<k;i++)cout<<str[i]<<blank<<str[N-i-1]<<endl;cout<<str.substr(k,n2)<<endl;return 0;
}
  相关解决方案