当前位置: 代码迷 >> 综合 >> PAT甲级-1032 Sharing (25分)
  详细解决方案

PAT甲级-1032 Sharing (25分)

热度:56   发布时间:2023-09-26 23:40:33.0

点击链接PAT甲级-AC全解汇总

题目:
To store English words, one method is to use linked lists and store a word letter by letter. To save some space, we may let the words share the same sublist if they share the same suffix. For example, loading and being are stored as showed in Figure 1.

PAT甲级-1032 Sharing (25分)

Figure 1

You are supposed to find the starting position of the common suffix (e.g. the position of i in Figure 1).

Input Specification:
Each input file contains one test case. For each case, the first line contains two addresses of nodes and a positive N (≤10?5?? ), where the two addresses are the addresses of the first nodes of the two words, and N is the total number of nodes. The address of a node is a 5-digit positive integer, and NULL is represented by ?1.
Then N lines follow, each describes a node in the format:

Address Data Next

where Address is the position of the node, Data is the letter contained by this node which is an English letter chosen from { a-z, A-Z }, and Next is the position of the next node.

Output Specification:
For each case, simply output the 5-digit starting position of the common suffix. If the two words have no common suffix, output -1 instead.

Sample Input 1:

11111 22222 9
67890 i 00002
00010 a 12345
00003 g -1
12345 D 67890
00002 n 00003
22222 B 23456
11111 L 00001
23456 e 67890
00001 o 00010

Sample Output 1:

67890

Sample Input 2:

00001 00002 4
00001 a 10001
10001 s -1
00002 a 10002
10002 t -1

Sample Output 2:

-1

题意:
两个字符串用链表的形式输出,找到第一个公共结点

我的思路:
其实这道题和输入的字符没有关系,只要找到第一个共同的结点下标,后面肯定就都一样了,所以找到第一个就好;

我的代码:

#include<bits/stdc++.h>
using namespace std;int main()
{
    int add_next[100100]={
    0};int flag[100100]={
    0};int start1,start2,N;cin>>start1>>start2>>N;for(int i=0;i<N;i++){
    int add,next;char c;cin>>add>>c>>next;add_next[add]=next;}while(start1!=-1){
    flag[start1]=true;start1=add_next[start1];}while(start2!=-1&&!flag[start2]){
    start2=add_next[start2];}if(start2==-1)printf("-1");else printf("%05d",start2);return 0;
}

算法笔记的的代码:

#include<cstdio>
#include<cstring>
const int maxn=100010;
struct NODE{
    char data;int next;bool flag;
}node[maxn];
int main(){
    for(int i=0;i<maxn;i++){
    node[i].flag=false;}int n,s1,s2;scanf("%d %d %d",&s1,&s2,&n);for(int i=0;i<n;i++){
    int address,next;char data;scanf("%d %c %d",&address,&data,&next);node[address].data=data;node[address].next=next;}int p;for(p=s1;p!=-1;p=node[p].next){
    node[p].flag=true;}for(p=s2;p!=-1;p=node[p].next){
    if(node[p].flag)break;}if(p!=-1)printf("%05d",p);elseprintf("-1");return 0;
}
  相关解决方案