当前位置: 代码迷 >> 综合 >> PAT甲级-1035 Password (20分)
  详细解决方案

PAT甲级-1035 Password (20分)

热度:96   发布时间:2023-09-26 23:37:41.0

点击链接PAT甲级-AC全解汇总

题目:
To prepare for PAT, the judge sometimes has to generate random passwords for the users. The problem is that there are always some confusing passwords since it is hard to distinguish 1 (one) from l (L in lowercase), or 0 (zero) from O (o in uppercase). One solution is to replace 1 (one) by @, 0 (zero) by %, l by L, and O by o. Now it is your job to write a program to check the accounts generated by the judge, and to help the juge modify the confusing passwords.

Input Specification:
Each input file contains one test case. Each case contains a positive integer N (≤1000), followed by N lines of accounts. Each account consists of a user name and a password, both are strings of no more than 10 characters with no space.

Output Specification:
For each test case, first print the number M of accounts that have been modified, then print in the following M lines the modified accounts info, that is, the user names and the corresponding modified passwords. The accounts must be printed in the same order as they are read in. If no account is modified, print in one line There are N accounts and no account is modified where N is the total number of accounts. However, if N is one, you must print There is 1 account and no account is modified instead.

Sample Input 1:

3
Team000002 Rlsp0dfa
Team000003 perfectpwd
Team000001 R1spOdfa

Sample Output 1:

2
Team000002 RLsp%dfa
Team000001 R@spodfa

Sample Input 2:

1
team110 abcdefg332

Sample Output 2:

There is 1 account and no account is modified

Sample Input 3:

2
team110 abcdefg222
team220 abcdefg333

Sample Output 3:

There are 2 accounts and no account is modified

题意:

输入名字和密码,如果密码有以下四个字符的话就给他修改,如果没有就跳过。
输出所有修改的,如果没有修改的就输出一句话,说都没有需要改变的

  • 1(数字1)→@
  • 0(数字0)→%
  • l(字母l)→L
  • O(字母O)→o

注意: 都没有需要改变的两句话中 is/are 和有没有 s 两个不同点

我的代码:

#include<bits/stdc++.h>
using namespace std;
class Id_password{
    
public:Id_password(string a,string b):name(a),password(b){
    }string name,password;
};
bool change(string& str){
    bool flag=false;for(int i=0;i<str.length();i++){
    if(str[i]!='1'&&str[i]!='0'&&str[i]!='l'&&str[i]!='O')continue;if(str[i]=='1')str[i]='@';else if(str[i]=='0')str[i]='%';else if(str[i]=='l')str[i]='L';else if(str[i]=='O')str[i]='o';flag=true;}return flag;
}
int main(){
    vector<Id_password>res;int N;cin>>N;for(int i=0;i<N;i++){
    string id,pass;cin>>id>>pass;if(!change(pass))continue;Id_password t(id,pass);res.push_back(t);}if(!res.size())if(N==1)printf("There is 1 account and no account is modified");else printf("There are %d accounts and no account is modified",N);else{
    cout<<res.size()<<endl;for(auto it:res)cout<<it.name<<" "<<it.password<<endl;}return 0;
}
  相关解决方案