当前位置: 代码迷 >> 综合 >> PAT甲级-1039 Course List for Student (25分)
  详细解决方案

PAT甲级-1039 Course List for Student (25分)

热度:129   发布时间:2023-09-26 23:34:27.0

点击链接PAT甲级-AC全解汇总

题目:
Zhejiang University has 40000 students and provides 2500 courses. Now given the student name lists of all the courses, you are supposed to output the registered course list for each student who comes for a query.

Input Specification:
Each input file contains one test case. For each case, the first line contains 2 positive integers: N (≤40,000), the number of students who look for their course lists, and K (≤2,500), the total number of courses. Then the student name lists are given for the courses (numbered from 1 to K) in the following format: for each course i, first the course index i and the number of registered students N?i?? (≤200) are given in a line. Then in the next line, N?i?? student names are given. A student name consists of 3 capital English letters plus a one-digit number. Finally the last line contains the N names of students who come for a query. All the names and numbers in a line are separated by a space.

Output Specification:
For each test case, print your results in N lines. Each line corresponds to one student, in the following format: first print the student’s name, then the total number of registered courses of that student, and finally the indices of the courses in increasing order. The query results must be printed in the same order as input. All the data in a line must be separated by a space, with no extra space at the end of the line.

Sample Input:

11 5
4 7
BOB5 DON2 FRA8 JAY9 KAT3 LOR6 ZOE1
1 4
ANN0 BOB5 JAY9 LOR6
2 7
ANN0 BOB5 FRA8 JAY9 JOE4 KAT3 LOR6
3 1
BOB5
5 9
AMY7 ANN0 BOB5 DON2 FRA8 JAY9 KAT3 LOR6 ZOE1
ZOE1 ANN0 BOB5 JOE4 JAY9 FRA8 DON2 AMY7 KAT3 LOR6 NON9

Sample Output:

ZOE1 2 4 5
ANN0 3 1 2 5
BOB5 5 1 2 3 4 5
JOE4 1 2
JAY9 4 1 2 4 5
FRA8 3 2 4 5
DON2 2 4 5
AMY7 1 5
KAT3 3 2 4 5
LOR6 4 1 2 4 5
NON9 0

题意:
输入学生数,课程数;
每个课程的编号,有多少学生上这门课,以及所有学生的名字;
按照最后一行学生的名字输出这个学生选课的数目,以及这些课的编号;

我的思路:
用一个map把学生的name对应到他的set,把课存到每个学生set里面就好;

我的代码:

#include<bits/stdc++.h>
using namespace std;int main(){
    map<string,set<int> >name_couse;int num_stu,num_couse;cin>>num_stu>>num_couse;for(int i=0;i<num_couse;i++){
    int id_couse,num;cin>>id_couse>>num;for(int j=0;j<num;j++){
    string name;cin>>name;name_couse[name].insert(id_couse);}}for(int i=0;i<num_stu;i++){
    string name;cin>>name;cout<<name<<" "<<name_couse[name].size();for(auto it:name_couse[name])cout<<" "<<it;cout<<endl;}return 0;
}
  相关解决方案