当前位置: 代码迷 >> 综合 >> PAT甲级-1041 Be Unique (20分)
  详细解决方案

PAT甲级-1041 Be Unique (20分)

热度:86   发布时间:2023-09-26 23:32:57.0

点击链接PAT甲级-AC全解汇总

题目:
Being unique is so important to people on Mars that even their lottery is designed in a unique way. The rule of winning is simple: one bets on a number chosen from [1,10?4?? ]. The first one who bets on a unique number wins. For example, if there are 7 people betting on { 5 31 5 88 67 88 17 }, then the second one who bets on 31 wins.

Input Specification:
Each input file contains one test case. Each case contains a line which begins with a positive integer N (≤10?5?? ) and then followed by N bets. The numbers are separated by a space.

Output Specification:
For each test case, print the winning number in a line. If there is no winner, print None instead.

Sample Input 1:

7 5 31 5 88 67 88 17

Sample Output 1:

31

Sample Input 2:

5 888 666 666 888 888

Sample Output 2:

None

题意:

输入一堆数,返回第一个只出现了一次的数

我的代码:

#include<bits/stdc++.h>
using namespace std;int main()
{
    int N,nums[100100]={
    0},times[100100]={
    0};cin>>N;for(int i=0;i<N;i++){
    cin>>nums[i];times[nums[i]]++;}for(int i=0;i<N;i++){
    if(times[nums[i]]==1){
    cout<<nums[i]<<endl;return 0;}}cout<<"None"<<endl;return 0;
}
  相关解决方案