当前位置: 代码迷 >> 综合 >> Bomb(数位DP板题)
  详细解决方案

Bomb(数位DP板题)

热度:4   发布时间:2024-02-24 00:24:16.0

题目链接:Bomb
Problem Description
The counter-terrorists found a time bomb in the dust. But this time the terrorists improve on the time bomb. The number sequence of the time bomb counts from 1 to N. If the current number sequence includes the sub-sequence “49”, the power of the blast would add one point.
Now the counter-terrorist knows the number N. They want to know the final points of the power. Can you help them?

Input
The first line of input consists of an integer T (1 <= T <= 10000), indicating the number of test cases. For each test case, there will be an integer N (1 <= N <= 2^63-1) as the description.

The input terminates by end of file marker.

Output
For each test case, output an integer indicating the final points of the power.

Sample Input
3
1
50
500

Sample Output
0
1
15

Hint
From 1 to 500, the numbers that include the sub-sequence “49” are “49”,“149”,“249”,“349”,“449”,“490”,“491”,“492”,“493”,“494”,“495”,“496”,“497”,“498”,“499”,
so the answer is 15.

题意是问我们从1~N中有多少个包含了“49”的数。
做法,数位DP板子题
dp[i][j][k]表示在第i位的位置上,j(0,1)表示前面有没有出现49,k(0,1)表示前一位是不是4;

#include<algorithm>
#include<string.h>
#include<iostream>
#include<stdio.h>
#include<string>
#include<math.h>
#include<vector>
#include<queue>
#include<stack>
#include<map>
#include<set>
#define emplace_back push_back
#define pb push_back
using namespace std;
typedef long long LL;
const LL mod = 1e9 + 7;
const double eps = 1e-6;
const LL inf = 0x3f3f3f3f;
const LL N = 2e5 + 10;
LL dp[50][2][2];
LL a[50];
LL dfs(LL pos,LL sta,LL limit,LL pre)
{
    if(pos<0){
    return sta;}if(!limit&&dp[pos][sta][pre]!=-1){
    return dp[pos][sta][pre];}LL up = limit ? a[pos] : 9;LL res = 0;for (LL i = 0; i <= up;i++){
    if(i==9&&pre){
    res += dfs(pos - 1,sta|1, limit && a[pos] == i, i==4);}else{
    res+=dfs(pos - 1,sta, limit && a[pos] == i, i==4);}}if(!limit)dp[pos][sta][pre] = res;return res;
}
LL solve(LL x)
{
    LL tot = 0;while(x){
    a[tot++] = x % 10;x /= 10;}return dfs(tot-1,0,1,0);
}
int main()
{
    LL t;scanf("%lld", &t);while(t--){
    LL n;scanf("%lld", &n);memset(dp, -1, sizeof(dp));printf("%lld\n", solve(n));}return 0;
}