当前位置: 代码迷 >> 综合 >> Common Subsequence HDU - 1159( 动态规划 最长公共子序列)
  详细解决方案

Common Subsequence HDU - 1159( 动态规划 最长公共子序列)

热度:42   发布时间:2024-02-22 13:29:13.0

A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = <x1, x2, …, xm> another sequence Z = <z1, z2, …, zk> is a subsequence of X if there exists a strictly increasing sequence <i1, i2, …, ik> of indices of X such that for all j = 1,2,…,k, xij = zj. For example, Z = <a, b, f, c> is a subsequence of X = <a, b, c, f, b, c> with index sequence <1, 2, 4, 6>. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y.
The program input is from a text file. Each data set in the file contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct. For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line.

Input

abcfbc abfcab
programming contest 
abcd mnp

Output

4
2
0

Sample Input

abcfbc abfcab
programming contest 
abcd mnp

Sample Output

4
2
0

思路:

代码:


```cpp
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
char a[10000],b[10000];
int dp[1000][1000];
int main()
{
    while(~scanf("%s %s",a+1,b+1)){
    memset(dp,0,sizeof(dp));int i,j;int l=strlen(a+1);int l1=strlen(b+1);for(i=1; i<=l; i++)dp[i][0]=0;for(j=1; j<=l1; j++)dp[0][j]=0;int maxx=0;for(i=1; i<=l; i++){
    for(j=1; j<=l1; j++){
    if(a[i]==b[j])dp[i][j]=dp[i-1][j-1]+1;else dp[i][j]=max(dp[i-1][j],dp[i][j-1]);maxx=max(dp[i][j],maxx);//放在for循环内每次要更新}}printf("%d\n",maxx);}return 0;
}

  相关解决方案