当前位置: 代码迷 >> 综合 >> PAT (Advanced Level)1136 A Delayed Palindrome (20分)
  详细解决方案

PAT (Advanced Level)1136 A Delayed Palindrome (20分)

热度:11   发布时间:2024-02-07 22:06:13.0

Consider a positive integer N written in standard notation with k+1 digits a?i?? as a?k???a?1??a?0?? with 0≤a?i??<10 for all i and a?k??>0. Then N is palindromic if and only if a?i??=a?k?i?? for all i. Zero is written 0 and is also palindromic by definition.

Non-palindromic numbers can be paired with palindromic ones via a series of operations. First, the non-palindromic number is reversed and the result is added to the original number. If the result is not a palindromic number, this is repeated until it gives a palindromic number. Such number is called a delayed palindrome. (Quoted from https://en.wikipedia.org/wiki/Palindromic_number )

Given any positive integer, you are supposed to find its paired palindromic number.

Input Specification:

Each input file contains one test case which gives a positive integer no more than 1000 digits.

Output Specification:

For each test case, print line by line the process of finding the palindromic number. The format of each line is the following:

A + B = C

where A is the original number, B is the reversed A, and C is their sum. A starts being the input number, and this process ends until C becomes a palindromic number -- in this case we print in the last line C is a palindromic number.; or if a palindromic number cannot be found in 10 iterations, print Not found in 10 iterations. instead.

Sample Input 1:

97152

Sample Output 1:

97152 + 25179 = 122331
122331 + 133221 = 255552
255552 is a palindromic number.

Sample Input 2:

196

Sample Output 2:

196 + 691 = 887
887 + 788 = 1675
1675 + 5761 = 7436
7436 + 6347 = 13783
13783 + 38731 = 52514
52514 + 41525 = 94039
94039 + 93049 = 187088
187088 + 880781 = 1067869
1067869 + 9687601 = 10755470
10755470 + 07455701 = 18211171
Not found in 10 iterations.

代码

#include<stdio.h>
#include<string.h>
#include<algorithm>using namespace std;const int maxn=1010;
int n,m,k,num;
char s[maxn];
struct bign{				//定义bign结构体,存储长度和整型数据 int len,d[maxn];bign(){len=0;memset(d,0,sizeof(d));}
};bool isparlindrome(bign a){	//判断是否回文 for(int i=0;i<a.len/2;i++)if(a.d[i]!=a.d[a.len-1-i])return false;return true;
}bign change(char str[]){	//把字符数组转换成bign结构体,倒序转换 bign a;a.len=strlen(str);for(int i=0;i<a.len;++i)	//低位所在位置下标小 a.d[i]=str[a.len-1-i]-'0';return a;
}void print(bign a){			//把结构体a中数据倒序打印出 for(int i=a.len-1;i>=0;i--)printf("%d",a.d[i]); 
}bign invert(bign a){		//返回值是结构体a的倒序 bign b;b.len=a.len;for(int i=0;i<a.len;i++)b.d[i]=a.d[a.len-1-i];while(b.d[b.len-1]==0&&b.len>1)	//如果高位是0,那就将len减小 b.len--;return b;
}bign add(bign a,bign b){	//从低位到高位累加 bign c;c.len=max(a.len,b.len);int carry=0;for(int i=0;i<c.len;++i){int temp=a.d[i]+b.d[i]+carry;c.d[i]=temp%10;carry=temp/10;}if(carry!=0)c.d[c.len++]=carry;return c;
} int main(){scanf("%s",s);bool flag=false;bign c=change(s);//print(c);for(int i=0;i<=10;++i){if(isparlindrome(c)){	//一开始的c就要判断是否回文! flag=true;break;}if(i==10)break;bign a=c;bign b=invert(c);print(a);printf(" + ");print(b);printf(" = ");c=add(a,b);print(c);printf("\n");} if(flag){print(c);printf(" is a palindromic number.\n");}elseprintf("Not found in 10 iterations.\n");return 0;
} 

参考链接:https://blog.csdn.net/a845717607/article/details/87970347

  相关解决方案