当前位置: 代码迷 >> 综合 >> POJ 1733 Parity game
  详细解决方案

POJ 1733 Parity game

热度:94   发布时间:2024-02-02 18:42:03.0

题目链接

Description

Now and then you play the following game with your friend. Your friend writes down a sequence consisting of zeroes and ones. You choose a continuous subsequence (for example the subsequence from the third to the fifth digit inclusively) and ask him, whether this subsequence contains even or odd number of ones. Your friend answers your question and you can ask him about another subsequence and so on. Your task is to guess the entire sequence of numbers.

You suspect some of your friend’s answers may not be correct and you want to convict him of falsehood. Thus you have decided to write a program to help you in this matter. The program will receive a series of your questions together with the answers you have received from your friend. The aim of this program is to find the first answer which is provably wrong, i.e. that there exists a sequence satisfying answers to all the previous questions, but no such sequence satisfies this answer.

Input

The first line of input contains one number, which is the length of the sequence of zeroes and ones. This length is less or equal to 1000000000. In the second line, there is one positive integer which is the number of questions asked and answers to them. The number of questions and answers is less or equal to 5000. The remaining lines specify questions and answers. Each line contains one question and the answer to this question: two integers (the position of the first and last digit in the chosen subsequence) and one word which is either ‘even’ or ‘odd’ (the answer, i.e. the parity of the number of ones in the chosen subsequence, where ‘even’ means an even number of ones and ‘odd’ means an odd number).

Output

There is only one line in output containing one integer X. Number X says that there exists a sequence of zeroes and ones satisfying first X parity conditions, but there exists none satisfying X+1 conditions. If there exists a sequence of zeroes and ones satisfying all the given conditions, then number X should be the number of all the questions asked.

Sample Input

10
5
1 2 even
3 4 odd
5 6 even
1 6 even
7 10 odd

Sample Output

3

大致题意
一个很长很长的只包含01的字符串,多组数据,第一行一个数 t 表示有 t 个点,接下来一个 n 表示有 n 个关系,之后 n 行,每一行两个数字和一个字符串,表示(a,b] 的区间内1的个数是奇数还是偶数,问第一个出现冲突的语句是哪一句,如果没有冲突语句输出 n(注意冲突语句序号是从0开始的)

具体思路
最近并查集做着做着越来越像链式前向星了,做过前面那一题区间长度的并查集这题应该不是什么问题,只要将并查过程中长度的变换改成奇偶位运算就可以了,这道题目有个比较特殊的地方,因为点的个数较大,但因为输出样例只有5000组,这表示最多只含有1W的点数,因此在这里需要将原有较大的点数用离散化哈希处理一下

#include<stdio.h>
#include<algorithm>
#include<iostream>
#include<math.h>
#include<string.h>
#include<queue>
#include<map>
using namespace std;
typedef long long LLD;
const LLD maxdot=1e4+50;
LLD num,dot[maxdot],sum[maxdot];
map<LLD,LLD>m;
LLD findroot(LLD x)
{if (dot[x]==-1){return x;}int number=findroot(dot[x]);sum[x]^=sum[dot[x]];return dot[x]=number;
}
LLD addmap(LLD x)
{if (m.find(x)==m.end()){m[x]=num++;}return m[x];
}
int main()
{LLD t;while (scanf("%lld",&t)!=EOF){LLD n,ans;scanf("%lld",&n);ans=n;num=0;memset(dot,-1,sizeof(dot));memset(sum,0,sizeof(sum));for (LLD i=0;i<n;i++){LLD dot1,dot2;char number[10];scanf("%lld %lld %s%*c",&dot1,&dot2,&number);if (ans<n){continue;}if (dot1>dot2){swap(dot1,dot2);}dot1=addmap(dot1-1);dot2=addmap(dot2);LLD tmp;if (number[0]=='e'){tmp=0;}else{tmp=1;}LLD root1=findroot(dot1);LLD root2=findroot(dot2);if (root1==root2){if (sum[dot1]^sum[dot2]!=tmp){ans=i;}}else{dot[root2]=root1;sum[root2]=tmp^sum[dot1]^sum[dot2];}}printf("%lld\n",ans);}return 0;
}
  相关解决方案