当前位置: 代码迷 >> 综合 >> HDU 1686 Oulipo hash算法模板题
  详细解决方案

HDU 1686 Oulipo hash算法模板题

热度:23   发布时间:2024-02-02 04:40:51.0

学习博客地址https://www.cnblogs.com/FrankChen831X/p/12401300.html

4种Hash做法:自然溢出(推荐)、单Hash、双Hash、模1e18级别的质数(推荐)

常用进制 base=131

模数 19260817, 19660813;
212370440130137957 //1e18位的质数
19260817*19890604-19491001

Oulipo

Problem Description
The French author Georges Perec (1936–1982) once wrote a book, La disparition, without the letter ‘e’. He was a member of the Oulipo group. A quote from the book:

Tout avait Pair normal, mais tout s’affirmait faux. Tout avait Fair normal, d’abord, puis surgissait l’inhumain, l’affolant. Il aurait voulu savoir où s’articulait l’association qui l’unissait au roman : stir son tapis, assaillant à tout instant son imagination, l’intuition d’un tabou, la vision d’un mal obscur, d’un quoi vacant, d’un non-dit : la vision, l’avision d’un oubli commandant tout, où s’abolissait la raison : tout avait l’air normal mais…

Perec would probably have scored high (or rather, low) in the following contest. People are asked to write a perhaps even meaningful text on some subject with as few occurrences of a given “word” as possible. Our task is to provide the jury with a program that counts these occurrences, in order to obtain a ranking of the competitors. These competitors often write very long texts with nonsense meaning; a sequence of 500,000 consecutive 'T’s is not unusual. And they never use spaces.

So we want to quickly find out how often a word, i.e., a given string, occurs in a text. More formally: given the alphabet {‘A’, ‘B’, ‘C’, …, ‘Z’} and two finite strings over that alphabet, a word W and a text T, count the number of occurrences of W in T. All the consecutive characters of W must exactly match consecutive characters of T. Occurrences may overlap.

Input
The first line of the input file contains a single number: the number of test cases to follow. Each test case has the following format:

One line with the word W, a string over {‘A’, ‘B’, ‘C’, …, ‘Z’}, with 1 ≤ |W| ≤ 10,000 (here |W| denotes the length of the string W).
One line with the text T, a string over {‘A’, ‘B’, ‘C’, …, ‘Z’}, with |W| ≤ |T| ≤ 1,000,000.

Output
For every test case in the input file, the output should contain a single number, on a single line: the number of occurrences of the word W in the text T.

Sample Input
3
BAPC
BAPC
AZA
AZAZAZA
VERDI
AVERDXIVYERDIAN

Sample Output
1
3
0

#include <cstdio>
#include <iostream>
#include <cstring>
#include <queue>
#include <cmath>
#include <set>
#include <algorithm>
#include <map>
#include <vector>
using namespace std;
typedef unsigned long long ull;
const int N = 1e6+6;
const double inf = 0x3f3f3f3f;
const double eps = 1e-6;
const int bas = 27;ull hsh1[N], hsh2[N];
ull base[N];
ull mod = 1 << 31;
void init()
{base[0] = 1;for(int i = 1; i < N; ++i)base[i] = base[i-1]*bas%mod;
}ull make_hash(char s[], ull hsh[])
{int len = strlen(s);hsh[0] = 0;for(int i = 0; i < len; ++i)hsh[i+1] = (ull)(hsh[i]*bas+s[i]-'A'+1)%mod;return len;
}char s1[N], s2[N];int main()
{int t, i, ans;init();scanf("%d", &t);while(t--){ans = 0;scanf("%s%s", s1, s2);int len1 = make_hash(s1, hsh1);int len2 = make_hash(s2, hsh2);for(i = len1; i <= len2; ++i)if(hsh2[i]-hsh2[i-len1]*base[len1]%mod == hsh1[len1])++ans;printf("%d\n", ans);}return 0;
}