当前位置: 代码迷 >> 综合 >> How Many Answers Are Wrong(hdu-3038)
  详细解决方案

How Many Answers Are Wrong(hdu-3038)

热度:13   发布时间:2024-02-01 07:39:55.0

HDU - 3038 传送门

Problem Description

TT and FF are … friends. Uh… very very good friends -________-b
FF is a bad boy, he is always wooing TT to play the following game with him. This is a very humdrum game. To begin with, TT should write down a sequence of integers-_-!!(bored).
Then, FF can choose a continuous subsequence from it(for example the subsequence from the third to the fifth integer inclusively). After that, FF will ask TT what the sum of the subsequence he chose is. The next, TT will answer FF’s question. Then, FF can redo this process. In the end, FF must work out the entire sequence of integers.
BoringBoringa very very boring game!!! TT doesn’t want to play with FF at all. To punish FF, she often tells FF the wrong answers on purpose.
The bad boy is not a fool man. FF detects some answers are incompatible. Of course, these contradictions make it difficult to calculate the sequence.
However, TT is a nice and lovely girl. She doesn’t have the heart to be hard on FF. To save time, she guarantees that the answers are all right if there is no logical mistakes indeed.
What’s more, if FF finds an answer to be wrong, he will ignore it when judging next answers.
But there will be so many questions that poor FF can’t make sure whether the current answer is right or wrong in a moment. So he decides to write a program to help him with this matter. The program will receive a series of questions from FF together with the answers FF has received from TT. The aim of this program is to find how many answers are wrong. Only by ignoring the wrong answers can FF work out the entire sequence of integers. Poor FF has no time to do this job. And now he is asking for your help~(Why asking trouble for himself~~Bad boy)

Input

Line 1: Two integers, N and M (1 <= N <= 200000, 1 <= M <= 40000). Means TT wrote N integers and FF asked her M
questions.
Line 2…M+1: Line i+1 contains three integer: Ai, Bi and Si. Means TT answered FF that the sum from Ai to Bi is Si. It’s guaranteed that 0 < Ai <= Bi <= N.
You can assume that any sum of subsequence is fit in 32-bit integer.

Output

A single line with a integer denotes how many answers are wrong.

Sample Input

10 5
1 10 100
7 10 28
1 3 32
4 6 41
6 6 1

Sample Output

1


解题思路

带权并查集的题型,我们可以把 u~v 之间的和 w 解释成 v 的累加比到 u-1 的累加大 w 即: sum [v] - sum [u] = w
然后就是每次进行路径压缩的时候顺路更新一下sum值

AC代码

#include<iostream>
#include<algorithm>
#include<string.h>
using namespace std;
const int maxn = 211985;
int WA;
int fa[maxn];
int sum[maxn];
void init()
{for(int i = 0 ; i <= maxn ; i++){fa[i] = i;sum[i]= 0;	}
}
int Find(int x)//路径压缩的时候更新一下sum的值
{if(fa[x] == x){return x;}else{int tmp = Find(fa[x]);sum[x]= sum[x] + sum[fa[x]];//更新return fa[x] = tmp;//这里不能直接写成 return fa[x] = Find(fa[x]) }
}
void unite(int u,int v,int w)
{int x = Find(u);int y = Find(v);if( x != y )//属于不同集合{fa[y] = x;//合并sum[y]= sum[u] + w - sum[v] ;//更新 //这里可以看成是两个区间得叠加 [x,u] 和 [y,v]//更新的sum[y]其实就是[x,y]的和//sum[u] + w = [x,u] + [u,v]的和 然后 减去的 sum[v] 就是[y,v]的和 //然后就可以得到[x,y]的区间和 也 就是 sum[y]// u~v 之间的和是 w 可以解释成为到 v 的累加比到 u-1 的累加大 w 即: sum [v] - sum [u] = w }else if(sum[v] - sum[u] != w)//区间和不匹配(u,v]{WA++;}
}
int main()
{ios::sync_with_stdio(false),cin.tie(0),cout.tie(0);int n,m;while(cin>>n>>m){init();WA = 0;int u,v,w;for(int i = 0 ; i < m ; i++){cin>>u>>v>>w;//sum[v] - sum[u] 与 w 的关系u--;//(u,v]的和是w //ep:sum[5] - sum[2] 就是 区间 [3,5]的和 即 (2,5]的和 //(这也是u为什么-1的原因)unite(u,v,w);}cout<<WA<<endl;}return 0;
}
  相关解决方案