当前位置: 代码迷 >> 综合 >> POJ 1611 The Suspects
  详细解决方案

POJ 1611 The Suspects

热度:75   发布时间:2024-01-30 22:05:15.0

题目链接

Description

Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. To minimize transmission to others, the best strategy is to separate the suspects from others.
In the Not-Spreading-Your-Sickness University (NSYSU), there are many student groups. Students in the same group intercommunicate with each other frequently, and a student may join several groups. To prevent the possible transmissions of SARS, the NSYSU collects the member lists of all student groups, and makes the following rule in their standard operation procedure (SOP).
Once a member in a group is a suspect, all members in the group are suspects.
However, they find that it is not easy to identify all the suspects when a student is recognized as a suspect. Your job is to write a program which finds all the suspects.

Input

The input file contains several cases. Each test case begins with two integers n and m in a line, where n is the number of students, and m is the number of groups. You may assume that 0 < n <= 30000 and 0 <= m <= 500. Every student is numbered by a unique integer between 0 and n?1, and initially student 0 is recognized as a suspect in all the cases. This line is followed by m member lists of the groups, one line per group. Each line begins with an integer k by itself representing the number of members in the group. Following the number of members, there are k integers representing the students in this group. All the integers in a line are separated by at least one space.
A case with n = 0 and m = 0 indicates the end of the input, and need not be processed.

Output

For each case, output the number of suspects in one line.

Sample Input

100 4
2 1 2
5 10 13 11 12 14
2 0 1
2 99 2
200 2
1 5
5 1 2 3 4 5
1 0
0 0

Sample Output

4
1
1

大致题意
第一行给出两个数字 n、m,表示有 n 个人和 m 个团体,n 个人的编号从 0 到 n-1 ,接下来 m 行数据,每一行第一个数字 k 表示当前团体有 k 个成员,之后给出对应成员编号,最后问有几个人与0号成员有关系,多组数据输入直到 n、m 两个数字均为0为止

具体思路
并查集的裸题,因为询问的数字成员是0,所以在并查集结合的时候尽量使得小的结点作为父亲结点,使得所有的成员在并查集的过程之中都可以向0成员靠拢,开设一个计数数组num来记录有多少个成员与0成员有联系,每次并查之后将小的父亲结点的值往小的父亲结点里面累加即可

#include<stdio.h>
#include<iostream>
#include<algorithm>
#include<math.h>
#include<queue>
using namespace std;
const int maxdot=30050;
int num[maxdot],gather[maxdot];
void init(int n)
{for (int i=0;i<=n;i++){gather[i]=i;num[i]=1;}return ;
}
int findroot(int n)
{if (gather[n]==n)return n;return findroot(gather[n]);
}
void join(int one,int other)
{int oneroot=findroot(one),otherroot=findroot(other);if (oneroot!=otherroot){if (oneroot<otherroot){gather[otherroot]=oneroot;num[oneroot]=num[oneroot]+num[otherroot];}else{gather[oneroot]=otherroot;num[otherroot]+=num[oneroot];}}return ;
}
int main()
{int n,m;while (scanf("%d %d",&n,&m)&&(n+m)!=0){init(n);for (int i=1;i<=m;i++){int k;scanf("%d",&k);int one;for (int j=1;j<=k;j++){int other;scanf("%d",&other);if (j==1){one=other;}else{join(one,other);}}}printf("%d\n",num[0]);}return 0;
}