当前位置: 代码迷 >> 综合 >> 1058 选择题 (20分)测试点0与123有略微不同
  详细解决方案

1058 选择题 (20分)测试点0与123有略微不同

热度:44   发布时间:2024-01-26 19:09:01.0

批改多选题是比较麻烦的事情,本题就请你写个程序帮助老师批改多选题,并且指出哪道题错的人最多。
输入格式:

输入在第一行给出两个正整数 N(≤ 1000)和 M(≤ 100),分别是学生人数和多选题的个数。随后 M 行,每行顺次给出一道题的满分值(不超过 5 的正整数)、选项个数(不少于 2 且不超过 5 的正整数)、正确选项个数(不超过选项个数的正整数)、所有正确选项。注意每题的选项从小写英文字母 a 开始顺次排列。各项间以 1 个空格分隔。最后 N 行,每行给出一个学生的答题情况,其每题答案格式为 (选中的选项个数 选项1 ……),按题目顺序给出。注意:题目保证学生的答题情况是合法的,即不存在选中的选项数超过实际选项数的情况。
输出格式:

按照输入的顺序给出每个学生的得分,每个分数占一行。注意判题时只有选择全部正确才能得到该题的分数。最后一行输出错得最多的题目的错误次数和编号(题目按照输入的顺序从 1 开始编号)。如果有并列,则按编号递增顺序输出。数字间用空格分隔,行首尾不得有多余空格。如果所有题目都没有人错,则在最后一行输出 Too simple。
输入样例:

3 4
3 4 2 a c
2 5 1 b
5 3 2 b c
1 5 4 a b d e
(2 a c) (2 b d) (2 a c) (3 a b e)
(2 a c) (1 b) (2 a b) (4 a b d e)
(2 b d) (1 e) (2 b c) (4 a b c d)

输出样例:

3
6
5
2 2 3 4

思路:1.先给每个课程一个结构体,记录做对的学生数、分数和正确答案;

struct ss {int score, stunum;string all, right;//all读取整个课程信息。例如:3 4 2 a css() {stunum = 0;}
}s[110];

观察一下,对于我们判断这题学生答案对不对,有用的信息只有:2 a c。注意空格也算,方便判断;
而对于一个学生整行读入的str,如:(2 a c) (2 b d) (2 a c) (3 a b e)。我们只需要判断()之内的字符串是不是和right相等即可

s[i].right = s[i].all.substr(4, s[i].all.length()-4);//提取正确答案int j = 0, k = 0, sum = 0;while (j < m) {for (; k < str.length(); k++) {//每次读到‘(’就开始判断if (str[k] == '(') {//len为了计算学生写的答案长度int len = str[k + 1] - '0';//如:(2 a c) (2 b d) (2 a c) (3 a b e)//每次就截取()中的2 a c,2 b d,2 a c,3 a b e。然后和right判断是否相等;string str1 = str.substr(k + 1, len * 2 + 1);if (strcmp(str1.c_str(), s[j].right.c_str()) == 0) {//相等,把学生总成绩+score,对应课程答对的人数+1;sum += s[j].score;s[j].stunum++;}}//读到')'说明接下去是学生写的下一门的答案了;if (str[k] == ')')j++;}}

思路讲完直接上代码
还有一个比较坑的地方,之前用getchar(),发现题目给的样例输入n和m有两个回车,而测试样例123又只有1个。。。所以只能用cin.ignore(10, ‘\n’);消除之前遇到的回车。

    int n, m;cin >> n >> m;//getchar();cin.ignore(10, '\n');
#include <iostream>
#include <cmath>
#include <cstdio>
#include <iomanip>
#include <algorithm>
#include <map>
#include <stack>
#include <queue>
#include <string>
#include <list>
#include <cctype>
#include <memory.h>
#include <vector>
#include <set>
using namespace std;
struct ss {int score, stunum;string all, right;ss() {stunum = 0;}
}s[110];int main() {int n, m;cin >> n >> m;cin.ignore(10, '\n');for (int i = 0; i < m; i++) {getline(cin, s[i].all);s[i].score = s[i].all[0] - '0';s[i].right = s[i].all.substr(4, s[i].all.length()-4);}string str;for (int i = 0; i < n; i++) {getline(cin, str);int j = 0, k = 0, sum = 0;while (j < m) {for (; k < str.length(); k++) {if (str[k] == '(') {int len = str[k + 1] - '0';string str1 = str.substr(k + 1, len * 2 + 1);if (strcmp(str1.c_str(), s[j].right.c_str()) == 0) {sum += s[j].score;s[j].stunum++;}}if (str[k] == ')')j++;}}cout << sum << endl;}int minstu = 1100, p = 0;for (int i = 0; i < m; i++) {if (s[i].stunum < minstu) {minstu = s[i].stunum;}if (s[i].stunum == n) {p++;}}if (p == m) {cout << "Too simple" << endl;}else {cout << n - minstu;for (int i = 0; i < m; i++) {if (s[i].stunum == minstu)cout << " " << i + 1;}}
}