当前位置: 代码迷 >> 综合 >> SPFA判负环-Wormholes POJ - 3259
  详细解决方案

SPFA判负环-Wormholes POJ - 3259

热度:10   发布时间:2024-01-25 12:14:34.0

SPFA判负环-Wormholes POJ - 3259

题目:
While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ’s farms comprises N (1 ≤ N ≤ 500) fields conveniently numbered 1…N, M (1 ≤ M ≤ 2500) paths, and W (1 ≤ W ≤ 200) wormholes.

As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself ? .

To help FJ find out whether this is possible or not, he will supply you with complete maps to F (1 ≤ F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000 seconds.

Input
Line 1: A single integer, F. F farm descriptions follow.
Line 1 of each farm: Three space-separated integers respectively: N, M, and W
Lines 2… M+1 of each farm: Three space-separated numbers ( S, E, T) that describe, respectively: a bidirectional path between S and E that requires T seconds to traverse. Two fields might be connected by more than one path.
Lines M+2… M+ W+1 of each farm: Three space-separated numbers ( S, E, T) that describe, respectively: A one way path from S to E that also moves the traveler back T seconds.
Output
Lines 1… F: For each farm, output “YES” if FJ can achieve his goal, otherwise output “NO” (do not include the quotes).
Sample Input
2
3 3 1
1 2 2
1 3 4
2 3 1
3 1 3

3 2 1
1 2 3
2 3 4
3 1 8
Sample Output
NO
YES
Hint
For farm 1, FJ cannot travel back in time.
For farm 2, FJ could travel back in time by the cycle 1->2->3->1, arriving back at his starting location 1 second before he leaves. He could start from anywhere on the cycle to accomplish this.

题意:
输入点的数量N,边的数量M,虫洞数量W。
输入各边起点、终点、权值,虫洞起点、终点、权值。
判断从S到E的最短路权值是否小于通过虫洞从E到S的权值,即判断是否存在权值总和小于零的回路。

思路:
SPFA算法判断负环。
我们都知道spfa算法是对bellman算法的优化,那么如何用spfa算法来判断负权回路呢?我们考虑一个节点入队的条件是什么,只有那些在前一遍松弛中改变了距离估计值的点,才可能引起他们的邻接点的距离估计值的改变。因此,用一个先进先出的队列来存放被成功松弛的顶点。同样,我们有这样的定理:“两点间如果有最短路,那么每个结点最多经过一次。也就是说,这条路不超过n-1条边。”(如果一个结点经过了两次,那么我们走了一个圈。如果这个圈的权为正,显然不划算;如果是负圈,那么最短路不存在;如果是零圈,去掉不影响最优值)。也就是说,每个点最多入队n-1次(这里比较难理解,需要仔细体会,n-1只是一种最坏情况,实际中,这样会很大程度上影响程序的效率)。
有了上面的基础,思路就很显然了,加开一个数组记录每个点入队的次数(cnt),然后,判断当前入队的点的入队次数,如果大于n-1,则说明存在负权回路。

#include<iostream>
#include<queue>
#include<cstdio>
#include<cstring>
#define inf 0x3f3f3f3f
#define P pair<int,int>
using namespace std;
const int maxn=505;
const int maxm=5505;
int head[maxn],d[maxn],cnt[maxn];
bool vis[maxn];
int N,M,W,k=0,F,T;
struct node
{int v,next,w;
}a[maxm];void add(int u,int v,int w)
{a[++k].next=head[u];a[k].v=v;a[k].w=w;head[u]=k;
}bool spfa()
{memset(d,inf,sizeof(d));memset(cnt,0,sizeof(cnt));memset(vis,false,sizeof(vis));d[1]=0;cnt[1]=1;queue<int>q;q.push(1);while(q.size()){int u=q.front();q.pop();vis[u]=false;for(int i=head[u];i;i=a[i].next){int v=a[i].v,w=a[i].w;if(d[v]>d[u]+w){d[v]=d[u]+w;if(!vis[v])//一开始漏了,在同一层循环中遍历点,不可重复遍历{cnt[v]++;if(cnt[v]>N) return true;//有负环vis[v]=1;q.push(v);}}}}return false;
}int main()
{cin>>F;while(F--){k=0,memset(head,0,sizeof(head));//多个样例忘了重置//memset(a,NULL,sizeof(a));scanf("%d%d%d",&N,&M,&W);for(int i=1;i<=M;i++){int u,v,w;scanf("%d%d%d",&u,&v,&w);add(u,v,w);add(v,u,w);}for(int i=1;i<=W;i++){int u,v,w;scanf("%d%d%d",&u,&v,&w);add(u,v,-w);}if(!spfa()) cout<<"NO"<<endl;//没有负环else cout<<"YES"<<endl;}return 0;
}