当前位置: 代码迷 >> 综合 >> poj2299——BIT求逆序数
  详细解决方案

poj2299——BIT求逆序数

热度:2   发布时间:2024-01-21 01:42:51.0

传送门:http://poj.org/problem?id=2299

Ultra-QuickSort
Time Limit: 7000MS   Memory Limit: 65536K
Total Submissions: 63294   Accepted: 23614

Description

In this problem, you have to analyze a particular sorting algorithm. The algorithm processes a sequence of n distinct integers by swapping two adjacent sequence elements until the sequence is sorted in ascending order. For the input sequence 
9 1 0 5 4 ,

Ultra-QuickSort produces the output 
0 1 4 5 9 .

Your task is to determine how many swap operations Ultra-QuickSort needs to perform in order to sort a given input sequence.

Input

The input contains several test cases. Every test case begins with a line that contains a single integer n < 500,000 -- the length of the input sequence. Each of the the following n lines contains a single integer 0 ≤ a[i] ≤ 999,999,999, the i-th input sequence element. Input is terminated by a sequence of length n = 0. This sequence must not be processed.

Output

For every input sequence, your program prints a single line containing an integer number op, the minimum number of swap operations necessary to sort the given input sequence.

Sample Input

5
9
1
0
5
4
3
1
2
3
0

Sample Output

6
0

Source

Waterloo local 2005.02.05

题意:题目背景是有一种两两交换的排序,名字什么的不重要了,给出原顺序,问执行这样的排序之后需要交换多少次
可以把题目转化为求每个数之前出现了多少个数大于这个数本身,这样就变成了求逆序数
从数据量可以分析出,这个题里面很多数用不到,这里需要离散化一下
把9  1  0  5  4离散处理为5  2  1  4  3
之前贴海报的题看过,这样处理,数组相互之间的大小关系不变,但总数据范围更加集中了,其实离散化用的听广泛的
题目里面还有一些坑点以后需要注意
代码:
///poj2299
#include<iostream>
#include<cstring>
#include<string>
#include<cstdio>
#include<algorithm>
#define cl(a,b) memset(a,b,sizeof(a))
typedef long long ll;
using namespace std;
const int maxn=1e6+7;
struct node{int val,pos;
}a[maxn];
bool cmp(node a,node b){///排序写法很随意return a.val<b.val;
}
int n;
int c[maxn];
int flag[maxn];
int lowbit(int x){return x&(-x);
}
void modify(int x,int val){while(x<=n){c[x]+=val;x+=lowbit(x);}
}
int sum(int x){int ans=0;while(x>0){ans+=c[x];x-=lowbit(x);}return ans;
}
int main(){int i,j;while(~scanf("%d",&n),n){for(i=1;i<=n;i++){scanf("%d",&a[i].val);a[i].pos=i;}sort(a+1,a+n+1,cmp);///都是从1开始的就需要+1,不小心就WA了for(i=1;i<=n;i++){///离散处理flag[a[i].pos]=i;c[i]=0;}ll ans=0;///小心超范围for(i=1;i<=n;i++){modify(flag[i],1);ans+=i-sum(flag[i]);///总数减去小于的数}printf("%lld\n",ans);}return 0;
}
/**
5
9
1
0
5
4
3
1
2
3
0
**/

求逆序的思路:

可以把数一个个插入到树状数组中, 每插入一个数, 统计比他小的数的个数,对应的逆序为 i- getsum( data[i] ),其中 i 为当前已经插入的数的个数, getsum( data[i] )为比 data[i] 小的数的个数,i- getsum( data[i] ) 即比 data[i] 大的个数, 即逆序的个数。最后需要把所有逆序数求和,就是在插入的过程中边插入边求和。


摘自: http://blog.csdn.net/cattycat/article/details/5640838