当前位置: 代码迷 >> 综合 >> 【hdu 1862】EXCEL排序 (sort 结构体)
  详细解决方案

【hdu 1862】EXCEL排序 (sort 结构体)

热度:97   发布时间:2024-01-18 01:47:26.0

EXCEL排序

 
Excel可以对一组纪录按任意指定列排序。现请你编写程序实现类似功能。
Input
测试输入包含若干测试用例。每个测试用例的第1行包含两个整数 N (<=100000) 和 C,其中 N 是纪录的条数,C 是指定排序的列号。以下有 N 
行,每行包含一条学生纪录。每条学生纪录由学号(6位数字,同组测试中没有重复的学号)、姓名(不超过8位且不包含空格的字符串)、成绩(闭区间[0, 100]内的整数)组成,每个项目间用1个空格隔开。当读到 N=0 时,全部输入结束,相应的结果不要输出。 
Output
对每个测试用例,首先输出1行“Case i:”,其中 i 是测试用例的编号(从1开始)。随后在 N 行中输出按要求排序后的结果,即:当 C=1 时,按学号递增排序;当 C=2时,按姓名的非递减字典序排序;当 C=3 
时,按成绩的非递减排序。当若干学生具有相同姓名或者相同成绩时,则按他们的学号递增排序。 
Sample Input
3 1
000007 James 85
000010 Amy 90
000001 Zoe 60
4 2
000007 James 85
000010 Amy 90
000001 Zoe 60
000002 James 98
4 3
000007 James 85
000010 Amy 90
000001 Zoe 60
000002 James 90
0 0
Sample Output
Case 1:
000001 Zoe 60
000007 James 85
000010 Amy 90
Case 2:
000010 Amy 90
000002 James 98
000007 James 85
000001 Zoe 60
Case 3:
000001 Zoe 60
000007 James 85
000002 James 90
000010 Amy 90


代码:
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
struct Student
{int num;char name[20];int  mark;
}p[10000];
bool cmp1(Student a,Student b)
{return a.num<b.num;
}
bool cmp2(Student a,Student b)
{int q;q=strcmp(a.name,b.name);if(q==0){return a.num<b.num;}else if(q==1){return false;}else if(q==-1){return true;		}
}
bool cmp3(Student a,Student b)
{if(a.mark==b.mark){return a.num<b.num;}return a.mark<b.mark;
}
int main()
{int N,C,i=1;scanf("%d%d",&N,&C);while(N){int j;for(j=0;j<N;j++){scanf("%d %s %d",&p[j].num,p[j].name,&p[j].mark);}printf("Case %d:\n",i++);if(C==1){sort(p,p+N,cmp1);for(j=0;j<N;j++)printf("%06d %s %d\n",p[j].num,p[j].name,p[j].mark);}if(C==2){sort(p,p+N,cmp2);for(j=0;j<N;j++)printf("%06d %s %d\n",p[j].num,p[j].name,p[j].mark);			}if(C==3){sort(p,p+N,cmp3);for(j=0;j<N;j++)printf("%06d %s %d\n",p[j].num,p[j].name,p[j].mark);			} scanf("%d%d",&N,&C);}return 0;
}



  相关解决方案