当前位置: 代码迷 >> 综合 >> Minimum Transport Cost(dijkstra输出路径)
  详细解决方案

Minimum Transport Cost(dijkstra输出路径)

热度:16   发布时间:2024-01-13 21:24:13.0

点击打开链接

一、题目:

Minimum Transport Cost Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)Total Submission(s) : 21   Accepted Submission(s) : 7Problem DescriptionThese are N cities in Spring country. Between each pair of cities there may be one transportation track or none. Now there is some cargo that should be delivered from one city to another. The transportation fee consists of two parts: 
The cost of the transportation on the path between these cities, anda certain tax which will be charged whenever any cargo passing through one city, except for the source and the destination cities.You must write a program to find the route which has the minimum cost.InputFirst is N, number of cities. N = 0 indicates the end of input.The data of path cost, city tax, source and destination cities are given in the input, which is of the form:a11 a12 ... a1N
a21 a22 ... a2N
...............
aN1 aN2 ... aNN
b1 b2 ... bNc d
e f
...
g hwhere aij is the transport cost from city i to city j, aij = -1 indicates there is no direct path between city i and city j. bi represents the tax of passing through city i. And the cargo is to be delivered from city c to city d, city e to city f, ..., and g = h = -1. You must output the sequence of cities passed by and the total cost which is of the form:OutputFrom c to d :
Path: c-->c1-->......-->ck-->d
Total cost : ......
......From e to f :
Path: e-->e1-->..........-->ek-->f
Total cost : ......Note: if there are more minimal paths, output the lexically smallest one. Print a blank line after each test case.Sample Input50 3 22 -1 43 0 5 -1 -122 5 0 9 20-1 -1 9 0 44 -1 20 4 05 17 8 3 11 33 52 4-1 -10Sample OutputFrom 1 to 3 :Path: 1-->5-->4-->3Total cost : 21From 3 to 5 :Path: 3-->4-->5Total cost : 16From 2 to 4 :Path: 2-->1-->5-->4Total cost : 17SourceAsia 1996, Shanghai (Mainland China)

二、代码:

#include<stdio.h>
#include<string.h>
#define max 0x7fffffff
int map[1005][1005];
int map1[1005][1005];
int b[1005];
int prev[1005];
int visit[1005];
int dist[1005];
void dijkstra(int v,int n)
{memset(dist,-1,sizeof(dist));memset(prev,0,sizeof(prev));for(int i=1;i<=n;i++){dist[i]=map[v][i];visit[i]=0;if(dist[i]==max)prev[i]=0;elseprev[i]=v;}visit[v]=1;dist[v]=0;for(int j=0;j<=n;j++){int min=max;int u;for(int i=1;i<=n;i++){if(dist[i]<min&&visit[i]==0){min=dist[i];u=i;}}visit[u]=1;for(int i=1;i<=n;i++){if(map[u][i]!=max&&visit[i]==0){int newdist=dist[u]+map[u][i];if(newdist<dist[i]){dist[i]=newdist;prev[i]=u;}}}}
}int main()
{int n;int s,e;int c[1005];while(scanf("%d",&n)!=EOF){memset(map1,-1,sizeof(map1));if(n==0)break;int p;for(int i=1; i<=n; i++){for(int j=1; j<=n; j++){scanf("%d",&map1[i][j]);}}for(int i=1; i<=n; i++)scanf("%d",&b[i]);while(scanf("%d%d",&s,&e)!=EOF){if(s==-1&&e==-1)break;memset(c,0,sizeof(c));for(int i=1; i<=n; i++){for(int j=1; j<=n; j++){if(map1[i][j]==-1||map1[i][j]==0)map[i][j]=max;else if(j==s||j==e)map[i][j]=map1[i][j];elsemap[i][j]=map1[i][j]+b[j];}}dijkstra(s,n);//for(int i=1; i<=n; i++)// printf("prev[%d]=%d ",i,prev[i]);//printf("\n");printf("From %d to %d :\n",s,e);printf("Path: ");printf("%d",s);int tmp=prev[e];int tmp1;for(int i=0; tmp!=s; i++){c[i]=tmp;tmp=prev[c[i]];tmp1=i;}for(int k=tmp1; k>=0; k--){printf("-->%d",c[k]);}printf("-->%d\n",e);printf("Total cost : %d\n",dist[e]);printf("\n");}}return 0;
}
/*
5
0 3 22 -1 4
3 0 5 -1 -1
22 5 0 9 20
-1 -1 9 0 4
4 -1 20 4 0
5 17 8 3 1
1 3
3 5
2 4
-1 -1
0
*/


 


 

  相关解决方案