当前位置: 代码迷 >> 综合 >> Balanced Lineup (基本线段树)
  详细解决方案

Balanced Lineup (基本线段树)

热度:97   发布时间:2024-01-13 21:21:28.0

点击打开链接

1、题目大意:

有N头牛,给定N头牛的高度,输出给定区间内最高牛的高度与最低牛的高度差

 

输入:第一行两个数N、Q分别代表N头牛,Q个操作区间

接下来输入N个数,代表N头牛的高度

接下来是Q个操作区间,每一个操作区间输出一个高度差

2、题目:

Balanced Lineup Time Limit : 10000/5000ms (Java/Other)   Memory Limit : 131072/65536K (Java/Other)Total Submission(s) : 6   Accepted Submission(s) : 3Problem DescriptionFor the daily milking, Farmer John's N cows (1 ≤ N ≤ 50,000) always line up in the same order. One day Farmer John decides to organize a game of Ultimate Frisbee with some of the cows. To keep things simple, he will take a contiguous range of cows from the milking lineup to play the game. However, for all the cows to have fun they should not differ too much in height.Farmer John has made a list of Q (1 ≤ Q ≤ 200,000) potential groups of cows and their heights (1 ≤ height ≤ 1,000,000). For each group, he wants your help to determine the difference in height between the shortest and the tallest cow in the group.InputLine 1: Two space-separated integers, N and Q. 
Lines 2..N+1: Line i+1 contains a single integer that is the height of cow i 
Lines N+2..N+Q+1: Two integers A and B (1 ≤ A ≤ B ≤ N), representing the range of cows from A to B inclusive.OutputLines 1..Q: Each line contains a single integer that is a response to a reply and indicates the difference in height between the tallest and shortest cow in the range.Sample Input6 3
1
7
3
4
2
5
1 5
4 6
2 2Sample Output6
3
0


 

3、代码:

#include<stdio.h>
#include<iostream>
using namespace std;
#define lson l,m,rt<<1
#define rson m+1,r,rt<<1|1
int ma[500005];
int mi[500005];//数组开到4倍
void build(int l,int r,int rt)
{if(l==r){scanf("%d",&ma[rt]);mi[rt]=ma[rt];return ;}int m=(l+r)>>1;build(lson);build(rson);ma[rt]=max(ma[rt<<1],ma[rt<<1|1]);mi[rt]=min(mi[rt<<1],mi[rt<<1|1]);
}
int queryma(int L,int R,int l,int r,int rt)
{if(L<=l&&R>=r)return ma[rt];int m=(l+r)>>1;int ret=0;if(L<=m)ret=max(ret,queryma(L,R,lson));if(R>m)ret=max(ret,queryma(L,R,rson));return ret;
}
int querymi(int L,int R,int l,int r,int rt)
{if(L<=l&&R>=r)return mi[rt];int m=(l+r)>>1;int ret=1000005;if(L<=m)ret=min(ret,querymi(L,R,lson));if(R>m)ret=min(ret,querymi(L,R,rson));return ret;
}
int main()
{int n,m,s,e;scanf("%d%d",&n,&m);build(1,n,1);for(int i=1;i<=m;i++){scanf("%d%d",&s,&e);printf("%d\n",queryma(s,e,1,n,1)-querymi(s,e,1,n,1));}return 0;
}
/*
6 3
1
7
3
4
2
5
1 5
4 6
2 2
*/