当前位置: 代码迷 >> 综合 >> hdu 2818 Building Block(并查集,输出一元素下边有多少)
  详细解决方案

hdu 2818 Building Block(并查集,输出一元素下边有多少)

热度:6   发布时间:2024-01-13 21:21:11.0

点击打开链接http://acm.hdu.edu.cn/showproblem.php?pid=2818

简单并查集,只是注意输出的是x下边有多少元素

1、题目大意:

john 正在玩积木,有N个积木编号为1、、、N,分成N堆,每堆只包含一个积木,然后做P次操作,操作分为2种,

M X Y:把包含X的一堆放到包含Y的一堆上,如果XY同在一堆上,不做处理

C X:计算出X积木下边有多少个积木

每次遇到C操作,输出数量

2、题目:

Building Block

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1729    Accepted Submission(s): 516

Problem Description
John are playing with blocks. There are N blocks (1 <= N <= 30000) numbered 1...N。Initially, there are N piles, and each pile contains one block. Then John do some operations P times (1 <= P <= 1000000). There are two kinds of operation:

M X Y : Put the whole pile containing block X up to the pile containing Y. If X and Y are in the same pile, just ignore this command.
C X : Count the number of blocks under block X

You are request to find out the output for each C operation.


 

Input
The first line contains integer P. Then P lines follow, each of which contain an operation describe above.


 

Output
Output the count for each C operations in one line.


 

Sample Input
  
   
6 M 1 6 C 1 M 2 4 M 2 6 C 3 C 4


 

Sample Output
  
   
1 0 2

3、代码:


 

#include<stdio.h>
#include<string.h>
int num[333333];
int set[333333];
int under[333333];
int find(int x)
{int tmp;if (x!=set[x]){tmp = find(set[x]);under[x] += under[set[x]];set[x] = tmp;}return set[x];}
void merge(int a,int b)
{int fx=find(a);int fy=find(b);if(fx!=fy){under[fx]=num[fy];num[fy]+=num[fx];set[fx]=fy;}
}
int main()
{int n,a,b;char s[5];while(scanf("%d",&n)!=EOF){memset(under,0,sizeof(under));for(int i=0; i<=n; i++)//初始化{set[i]=i;num[i]=1;}for(int i=0; i<n; i++){scanf("%s",s);if(s[0]=='M'){scanf("%d%d",&a,&b);merge(a,b);}else{scanf("%d",&a);find(a);printf("%d\n",under[a]);}}}return 0;
} 
/*
6
M 1 6
C 1
M 2 4
M 2 6
C 3
C 4
*/


 


  相关解决方案