当前位置: 代码迷 >> 综合 >> zoj 2111 Starship Troopers(树形DP)
  详细解决方案

zoj 2111 Starship Troopers(树形DP)

热度:88   发布时间:2024-01-13 20:48:31.0

1、http://acm.zju.edu.cn/onlinejudge/showProblem.do?problemId=1111

2、题目大意:

题意是说有n个洞形成一棵树,你有m个士兵,每个洞都有一定数量的虫子和一定概率的首脑。每个士兵可以攻击20只虫子。而且想要攻击下面的洞的虫子,必须要攻击上层的虫子,问你花费这m个士兵,最多可以得到多少概率的首脑。

定义dp[x][y]表示在x结点放置y个士兵可以获得的brains的最大值

状态转移方程:dp[x][j]=max(dp[x][j],dp[x][j-k]+dp[v][k]);

其中dp[x][j-k]+dp[v][k]表示在x结点留下j-k个士兵,在子节点留k个士兵

因为下层的依赖于上层的结点,用dfs(_)依次调用树上的每一个结点

3、题目:

Starship Troopers

Time Limit: 5 Seconds      Memory Limit: 32768 KB

You, the leader of Starship Troopers, are sent to destroy a base of the bugs. The base is built underground. It is actually a huge cavern, which consists of many rooms connected with tunnels. Each room is occupied by some bugs, and their brains hide in some of the rooms. Scientists have just developed a new weapon and want to experiment it on some brains. Your task is to destroy the whole base, and capture as many brains as possible.

To kill all the bugs is always easier than to capture their brains. A map is drawn for you, with all the rooms marked by the amount of bugs inside, and the possibility of containing a brain. The cavern's structure is like a tree in such a way that there is one unique path leading to each room from the entrance. To finish the battle as soon as possible, you do not want to wait for the troopers to clear a room before advancing to the next one, instead you have to leave some troopers at each room passed to fight all the bugs inside. The troopers never re-enter a room where they have visited before.

A starship trooper can fight against 20 bugs. Since you do not have enough troopers, you can only take some of the rooms and let the nerve gas do the rest of the job. At the mean time, you should maximize the possibility of capturing a brain. To simplify the problem, just maximize the sum of all the possibilities of containing brains for the taken rooms. Making such a plan is a difficult job. You need the help of a computer.


Input

The input contains several test cases. The first line of each test case contains two integers N (0 < N <= 100) and M (0 <= M <= 100), which are the number of rooms in the cavern and the number of starship troopers you have, respectively. The following N lines give the description of the rooms. Each line contains two non-negative integers -- the amount of bugs inside and the possibility of containing a brain, respectively. The next N - 1 lines give the description of tunnels. Each tunnel is described by two integers, which are the indices of the two rooms it connects. Rooms are numbered from 1 and room 1 is the entrance to the cavern.

The last test case is followed by two -1's.


Output

For each test case, print on a single line the maximum sum of all the possibilities of containing brains for the taken rooms.


Sample Input

5 10
50 10
40 10
40 20
65 30
70 30
1 2
1 3
2 4
2 5
1 1
20 7
-1 -1


Sample Output


50
7

4、AC代码:

#include<stdio.h>
#include<string.h>
#include<vector>
using namespace std;
#define N 110
vector<int> vec[N];
int bugs[N];
int brains[N];
int dp[N][N];//dp[x][y]表示x结点放置y个人获得的最大brain值
int visited[N];
void dfs(int x,int m)
{visited[x]=1;int t=(bugs[x]+19)/20;//x结点至少需要的人数for(int i=t;i<=m;i++)dp[x][i]=brains[x];for(int i=0;i<vec[x].size();i++){int v=vec[x][i];if(visited[v]==0){dfs(v,m);//dp[x][j-k]+dp[v][k]表示在x结点留下j-k个士兵,在子节点留k个士兵for(int j=m;j>t;j--)//逆序可以保证用到的子节点的值时没更新的{for(int k=1;j-k>=t;k++){dp[x][j]=max(dp[x][j],dp[x][j-k]+dp[v][k]);}}}}
}
int main()
{int n,m,x,y;while(scanf("%d%d",&n,&m)!=EOF){if(n==-1 && m==-1)break;memset(visited,0,sizeof(visited));memset(dp,0,sizeof(dp));for(int i=0;i<=n;i++)vec[i].clear();for(int i=1;i<=n;i++){scanf("%d%d",&bugs[i],&brains[i]);}for(int i=1;i<n;i++){scanf("%d%d",&x,&y);vec[x].push_back(y);vec[y].push_back(x);}if(m==0)printf("0\n");else{dfs(1,m);printf("%d\n",dp[1][m]);}}return 0;
}