当前位置: 代码迷 >> 综合 >> Marriage Match IV(最短路径+最大流)
  详细解决方案

Marriage Match IV(最短路径+最大流)

热度:54   发布时间:2024-01-13 20:09:06.0

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=3416

题目大意:求最短路的个数

题目思路:先用SPFA求出最短路径,然后用SAP算法求出最大网络流,即最短的个数,以最短路径上的边建图,用邻接链表存边

题目:

Marriage Match IV

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1478    Accepted Submission(s): 412


Problem Description
Do not sincere non-interference。
Like that show, now starvae also take part in a show, but it take place between city A and B. Starvae is in city A and girls are in city B. Every time starvae can get to city B and make a data with a girl he likes. But there are two problems with it, one is starvae must get to B within least time, it's said that he must take a shortest path. Other is no road can be taken more than once. While the city starvae passed away can been taken more than once.


So, under a good RP, starvae may have many chances to get to city B. But he don't know how many chances at most he can make a data with the girl he likes . Could you help starvae?

Input
The first line is an integer T indicating the case number.(1<=T<=65)
For each case,there are two integer n and m in the first line ( 2<=n<=1000, 0<=m<=100000 ) ,n is the number of the city and m is the number of the roads.

Then follows m line ,each line have three integers a,b,c,(1<=a,b<=n,0<c<=1000)it means there is a road from a to b and it's distance is c, while there may have no road from b to a. There may have a road from a to a,but you can ignore it. If there are two roads from a to b, they are different.

At last is a line with two integer A and B(1<=A,B<=N,A!=B), means the number of city A and city B.
There may be some blank line between each case.

Output
Output a line with a integer, means the chances starvae can get at most.

Sample Input
  
   
3 7 8 1 2 1 1 3 1 2 4 1 3 4 1 4 5 1 4 6 1 5 7 1 6 7 1 1 76 7 1 2 1 2 3 1 1 3 3 3 4 1 3 5 1 4 6 1 5 6 1 1 62 2 1 2 1 1 2 2 1 2

Sample Output
  
   
2 1 1
#include <iostream>
#include <queue>
#include <vector>
#include<string.h>
#include<stdio.h>
using namespace std;
const int inf=0x3f3f3f3f;
struct rec
{int u,v,w,link;
} edge[300005];
struct re
{int v,c;
};
vector<re> E[1005];
bool vis[1005];
int head[1005],pre[1005],cur[1005],dis[1005],gap[1005];
int n,m,num,st,ed;
inline void addedge(int u,int v,int w)
{edge[num].u=u;edge[num].v=v;edge[num].w=w;edge[num].link=head[u];head[u]=num++;edge[num].u=v;edge[num].v=u;edge[num].w=0;edge[num].link=head[v];head[v]=num++;
}
void SPFA()
{int i,v,u;memset(vis,0,sizeof(vis));for(i=1; i<=n; i++)dis[i]=inf;queue<int> Q;dis[st]=0;Q.push(st);while(!Q.empty()){u=Q.front();Q.pop();vis[u]=0;for(i=0; i<E[u].size(); i++){v=E[u][i].v;if(dis[v]>dis[u]+E[u][i].c){dis[v]=dis[u]+E[u][i].c;if(!vis[v]){vis[v]=1;Q.push(v);}}}}
}
int max_flow()
{int i,k,u,v,aug=inf,ans=0;memset(dis,0,sizeof(dis));memset(gap,0,sizeof(gap));gap[0]=n;u=pre[st]=st;for(i=1; i<=n; i++)cur[i]=head[i];while(dis[st]<n){
loop:for(i=cur[u]; i; i=cur[u]=edge[i].link){v=edge[i].v;if(dis[u]==dis[v]+1 && edge[i].w){pre[v]=u;u=v;if(aug>edge[i].w)aug=edge[i].w;if(v==ed){for(u=pre[v]; v!=st; v=u,u=pre[u]){edge[cur[u]].w-=aug;edge[cur[u]^1].w+=aug;}ans+=aug;aug=inf;}goto loop;}}k=n;for(i=head[u]; i; i=edge[i].link){v=edge[i].v;if(k>dis[v] && edge[i].w){cur[u]=i;k=dis[v];}}if(--gap[dis[u]]==0)break;gap[dis[u]=k+1]++;u=pre[u];}return ans;
}
int main()
{int T,i,j,u,v,c;re tmp;scanf("%d",&T);while(T--){scanf("%d%d",&n,&m);for(i=1; i<=n; i++)E[i].clear();num=2;memset(head,0,sizeof(head));for(i=1; i<=m; i++){scanf("%d%d%d",&u,&v,&c);if(u==v)continue;tmp.v=v;tmp.c=c;E[u].push_back(tmp);}scanf("%d%d",&st,&ed);SPFA();for(i=1; i<=n; i++)for(j=0; j<E[i].siz e(); j++)if(dis[E[i][j].v]==dis[i]+E[i][j].c)addedge(i,E[i][j].v,1);printf("%d\n",max_flow());}return 0;
}



  相关解决方案