当前位置: 代码迷 >> 综合 >> The most popular color of balloon
  详细解决方案

The most popular color of balloon

热度:14   发布时间:2024-01-12 16:09:07.0

题目:
Description
Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges' favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color and find the result.

This year, they decide to leave this lovely job to you.



Input


Input contains multiple test cases. Each test case starts with a number N (0 < N < 1000) -- the total number of balloons distributed. The next N lines contain one color each. The color of a balloon is a string of up to 15 lower-case letters.

A test case with N = 0 terminates the input and this test case is not to be processed.


Output


For each case, print the color of balloon for the most popular problem on a single line. It is guaranteed that there is a unique solution for each test case.


Sample Input


5
green
red
blue
red
red
3
pink
orange
pink
0


Sample Output


red
pink

解题思路:

首先想到用map映照容器来存放数据,string类型为主键,int为映照数据,每次循环输入n组数据,定义map<string,int> a;对于输入的字符串s,另a[s]++;此时若是a中已有s则其映照数据++,对于a中还没有s的情况,系统则自动入栈s,并对其的映照数据初始化为0,在输入完成后,输出映照数据最大的元素对应的主键

细节处理:

若用map,主键放string,别把int放在主键,
代码:

#include<bits/stdc++.h>
using namespace std;
int main()
{
    int n,i;while(cin>>n){
    map<string,int> a;string s,t;if(n==0) break;for(i=0;i<n;i++){
    cin>>s;a[s]++;}int max=0;map<string,int>::iterator it;for(it=a.begin();it!=a.end();it++){
    if((*it).second>max) {
    max=(*it).second;t=(*it).first;}}cout<<t<<endl;}return 0;
}

 

  相关解决方案