当前位置: 代码迷 >> 综合 >> Bad Hair Day//POJ - 3250//单调栈
  详细解决方案

Bad Hair Day//POJ - 3250//单调栈

热度:0   发布时间:2024-01-10 06:49:09.0

Bad Hair Day//POJ - 3250//单调栈


题目

Some of Farmer John’s N cows (1 ≤ N ≤ 80,000) are having a bad hair day! Since each cow is self-conscious about her messy hairstyle, FJ wants to count the number of other cows that can see the top of other cows’ heads.
Each cow i has a specified height hi (1 ≤ hi ≤ 1,000,000,000) and is standing in a line of cows all facing east (to the right in our diagrams). Therefore, cow i can see the tops of the heads of cows in front of her (namely cows i+1, i+2, and so on), for as long as these cows are strictly shorter than cow i.
Let ci denote the number of cows whose hairstyle is visible from cow i; please compute the sum of c1 through cN.For this example, the desired is answer 3 + 0 + 1 + 0 + 1 + 0 = 5.

Input
Line 1: The number of cows, N.
Lines 2…N+1: Line i+1 contains a single integer that is the height of cow i.
Output
Line 1: A single integer that is the sum of c 1 through cN.
Sample Input
6
10
3
7
4
12
2
Sample Output
5
题意
牛排队,能看到比自己矮的直到比自己高为止,求每个牛能看到的总和,不包括最高的那个
链接:https://vjudge.net/contest/352439#problem/I

思路

单调栈模板题

代码

#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>
#include <deque>
#include <cmath>
#include <stack>
#define pi 3.1415926
using namespace std;
typedef long long ll;
const ll mod = 1e9+7;int h[100000];
int main()
{
    int n;while(cin>>n){
    stack<int> cow;for(int i=0;i<n;i++){
    cin>>h[i];}ll ans=0;for(int i=0;i<n;i++){
    while(!cow.empty()&&cow.top()<=h[i])cow.pop();ans+=cow.size();cow.push(h[i]);}printf("%lld\n",ans);}return 0;
}

注意

ans用long long