当前位置: 代码迷 >> 综合 >> Balanced Lineup(线段树-树状数组)
  详细解决方案

Balanced Lineup(线段树-树状数组)

热度:41   发布时间:2024-01-05 05:30:11.0

点击打开链接



Balanced Lineup
Time Limit: 5000MS   Memory Limit: 65536K
Total Submissions: 55919   Accepted: 26205
Case Time Limit: 2000MS

Description

For the daily milking, Farmer John's N cows (1 ≤ N ≤ 50,000) always line up in the same order. One day Farmer John decides to organize a game of Ultimate Frisbee with some of the cows. To keep things simple, he will take a contiguous range of cows from the milking lineup to play the game. However, for all the cows to have fun they should not differ too much in height.

Farmer John has made a list of Q (1 ≤ Q ≤ 200,000) potential groups of cows and their heights (1 ≤ height ≤ 1,000,000). For each group, he wants your help to determine the difference in height between the shortest and the tallest cow in the group.

Input

Line 1: Two space-separated integers,  N and  Q
Lines 2.. N+1: Line  i+1 contains a single integer that is the height of cow  i 
Lines  N+2.. N+ Q+1: Two integers  A and  B (1 ≤  A ≤  B ≤  N), representing the range of cows from  A to  B inclusive.

Output

Lines 1.. Q: Each line contains a single integer that is a response to a reply and indicates the difference in height between the tallest and shortest cow in the range.

Sample Input

6 3
1
7
3
4
2
5
1 5
4 6
2 2

Sample Output

6
3
0

Source

USACO 2007 January Silver






Select Code

#include<iostream>
using namespace std;
const int INF = 0xffffff0;
int minV = INF;
int maxV = -INF;
struct Node		//不要左右子节点指针的做法 
{int L,R;int minV,maxV;int Mid(){return (L+R)/2;}
};
Node tree[800010];	//4倍叶子节点数量就够 void BuildTree(int root, int L, int R) {tree[root].L = L;tree[root].R = R;tree[root].minV = INF;tree[root].maxV = -INF;if(L!=R){BuildTree(2*root+1, L, (L+R)/2);BuildTree(2*root+2, (L+R)/2+1, R);}
}void Insert(int root, int i, int v) //将第i个数,其值为v,插入线段树  {if(tree[root].L == tree[root].R)	//成立则亦有tree[root].R==i {tree[root].minV = tree[root].maxV = v;return ;}tree[root].minV = min(tree[root].minV , v);//终于找到bug了 tree[root].maxV = max(tree[root].maxV , v);if(i <= tree[root].Mid())Insert(2*root + 1, i, v);elseInsert(2*root + 2, i, v);		
}void Query(int root, int s, int e) //查询区间[s,e]中的最大值和最小值,如果更优就记录在全局变量里  {if( tree[root].minV >= minV && tree[root].maxV <= maxV )return;if( tree[root].L == s && tree[root].R == e ){minV = min( minV, tree[root].minV );
// minV = min( minV, tree[root].minV );maxV = max( maxV, tree[root].maxV );return ;}if( e <= tree[root].Mid() )Query( 2*root + 1, s, e );else if( s > tree[root].Mid() )Query( 2*root + 2, s, e );else{Query( 2*root + 1, s, tree[root].Mid() );Query( 2*root + 2, tree[root].Mid() + 1, e );}}int main() {int n,q,h;int i,j,k;scanf("%d%d",&n,&q);BuildTree(0, 1, n);for(i=1; i<=n; i++){scanf("%d",&h);Insert(0, i, h);}for(i=0; i<q; i++){int s,e;scanf("%d%d",&s,&e);minV=INF;maxV=-INF;Query(0, s, e);printf("%d\n",maxV-minV);}return 0;
}