当前位置: 代码迷 >> 综合 >> HDOJ-1059 Dividing【多重背包】
  详细解决方案

HDOJ-1059 Dividing【多重背包】

热度:21   发布时间:2023-12-29 17:24:49.0

题目链接:HDU-1059

题目描述

Problem Description
Marsha and Bill own a collection of marbles. They want to split the collection among themselves so that both receive an equal share of the marbles. This would be easy if all the marbles had the same value, because then they could just split the collection in half. But unfortunately, some of the marbles are larger, or more beautiful than others. So, Marsha and Bill start by assigning a value, a natural number between one and six, to each marble. Now they want to divide the marbles so that each of them gets the same total value.
Unfortunately, they realize that it might be impossible to divide the marbles in this way (even if the total value of all marbles is even). For example, if there are one marble of value 1, one of value 3 and two of value 4, then they cannot be split into sets of equal value. So, they ask you to write a program that checks whether there is a fair partition of the marbles.

Input
Each line in the input describes one collection of marbles to be divided. The lines consist of six non-negative integers n1, n2, …, n6, where ni is the number of marbles of value i. So, the example from above would be described by the input-line ``1 0 1 2 0 0’’. The maximum total number of marbles will be 20000.

The last line of the input file will be ``0 0 0 0 0 0’’; do not process this line.

Output
For each colletcion, output Collection #k:'', where k is the number of the test case, and then eitherCan be divided.’’ or ``Can’t be divided.’’.

Output a blank line after each test case.

Sample Input
1 0 1 2 0 0
1 0 0 0 1 1
0 0 0 0 0 0

Sample Output
Collection #1:
Can’t be divided.

Collection #2:
Can be divided.

思路

这道题的题意是给定你6种玻璃珠的个数,然后每个玻璃珠的价值都是1.2…6;
然后询问你,能不能分配玻璃珠,使得拆分后,两堆玻璃珠的价值相同;

对于这道题,我们可以先统计出所有玻璃珠的总价值val,当总价值是奇数时,显然不可能均分。然后当总价值为偶数时,我们可以假设有一个容量为val/2的背包,然后对这个背包进行装物品; 如果最后加入的最大价值 = val/2 则可以平分,否则不可以均分;

AC代码:

#include <bits/stdc++.h>
using namespace std;#define long long long
#define INF 0x3f3f3f3f
#define MAX_N 20010int dp[1000010];
int v[10], w[10];int main()
{
    ios::sync_with_stdio(false);cin.tie(0);cout.tie(0);int ans = 0;int flag = 0;while(cin >> w[1] >> w[2] >> w[3] >> w[4] >> w[5] >> w[6]){
    ans++;if(flag)cout << endl;flag = 1;memset(dp, 0, sizeof(dp));int val = 0;for(int i = 1; i <= 6; i++){
    val += w[i] * i;}if(val == 0)break;cout << "Collection #" << ans << ":" << endl;if(val & 1){
    cout << "Can't be divided." << endl;continue;}for(int i = 1; i <= 6; i++){
    int tmp = w[i];for(int k = 1; ; k <<= 1){
    bool flag = 0;if(k > tmp){
    k = tmp;flag = 1;}for(int j = val / 2; j >= k * i; j--){
    dp[j] = max(dp[j], dp[j - k * i] + k * i);}tmp -= k;if(flag)break;}}if(dp[val / 2] == val / 2)cout << "Can be divided." << endl;elsecout << "Can't be divided." << endl;}return 0;
}