当前位置: 代码迷 >> 综合 >> HDOJ-2602 Bone Collector【01背包】
  详细解决方案

HDOJ-2602 Bone Collector【01背包】

热度:73   发布时间:2023-12-29 17:24:23.0

题目链接:HDU-2602

题目描述

Problem Description
Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?

Input
The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.

Output
One integer per line representing the maximum of the total value (this number will be less than 231).

Sample Input
1
5 10
1 2 3 4 5
5 4 3 2 1

Sample Output
14

思路

裸的01背包,没啥说的。

AC代码:

#include <bits/stdc++.h>
using namespace std;#define long long long
#define MAX_N 100010
#define INF 0x3f3f3f3fint v[1010], w[1010], dp[MAX_N];int main()
{
    ios::sync_with_stdio(false);cin.tie(0);cout.tie(0);int t;cin >> t;while(t--){
    memset(dp, 0, sizeof(dp));int n, T;cin >> n >> T;for(int i = 1; i <= n; i++){
    cin >> v[i];}for(int i = 1; i <= n; i++){
    cin >> w[i];}for(int i = 1; i <= n; i++){
    for(int j = T; j >= w[i]; j--){
    dp[j] = max(dp[j], dp[j - w[i]] + v[i]);}}cout << dp[T] << endl;}return 0;
}