当前位置: 代码迷 >> 综合 >> Box of Bricks
  详细解决方案

Box of Bricks

热度:75   发布时间:2023-12-29 06:18:03.0

Problem Description

Little Bob likes playing with his box of bricks. He puts the bricks one upon another and builds stacks of different height. “Look, I’ve built a wall!”, he tells his older sister Alice. “Nah, you should make all stacks the same height. Then you would have a real wall.”, she retorts. After a little consideration, Bob sees that she is right. So he sets out to rearrange the bricks, one by one, such that all stacks are the same height afterwards. But since Bob is lazy he wants to do this with the minimum number of bricks moved. Can you help?

Input
The input consists of several data sets. Each set begins with a line containing the number n of stacks Bob has built. The next line contains n numbers, the heights hi of the n stacks. You may assume 1≤n≤50 and 1≤hi≤100.
The total number of bricks will be divisible by the number of stacks. Thus, it is always possible to rearrange the bricks such that all stacks have the same height.
The input is terminated by a set starting with n = 0. This set should not be processed.
Output
For each set, print the minimum number of bricks that have to be moved in order to make all the stacks the same height.
Output a blank line between each set.

Sample Input

6
5 2 4 1 7 5
0 

Sample Output

Set #1
The minimum number of moves is 5.

Code:

//将每组的高度放入一个数组中,计算平均每组应该有的个数;遍历整个数组,找出高于平均值的差值即为最少搬动数目
#include<iostream>
using namespace std;int main() {
    int n,sum,aveg,count,j=0;while (cin >> n) {
    sum = 0; count = 0;if (n == 0) return 0;j++;if (n >= 1 && n <= 50) {
    int* hi = new int[n];for (int i = 0; i < n; i++) {
    cin >> hi[i];if (hi[i] < 1 || hi[i]>= 100) return 0;sum = sum + hi[i];}aveg = sum / n;for (int i = 0; i < n; i++) {
    int b = hi[i] - aveg;if (b > 0) {
    count = count + b;}}cout << "Set #" << j << endl;cout << "The minimum number of moves is " << count <<"."<< endl<<endl;}}
}