当前位置: 代码迷 >> 综合 >> 杭电oj1241:Oil Deposits
  详细解决方案

杭电oj1241:Oil Deposits

热度:34   发布时间:2023-12-28 08:09:46.0

Oil Deposits

链接

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 57905 Accepted Submission(s): 33183

Problem Description

The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid.

Input

The input file contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either *', representing the absence of oil, or@’, representing an oil pocket.

Output

For each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.

Sample Input
在这里插入图片描述

Sample Output

0
1
2
2

简单深搜思路:

#include<iostream>
using namespace std;const int M = 105;
const int N = 105;char c[M][N];
bool visit[M][N];
int m, n;void dfs(int i, int j)
{
    if(i<1 || i>m || j<1 || j>n)return;visit[i][j] = true;if(!visit[i+1][j] && c[i+1][j] == '@')dfs(i+1, j);if(!visit[i-1][j] && c[i-1][j] == '@')dfs(i-1, j);if(!visit[i][j+1] && c[i][j+1] == '@')dfs(i, j+1);if(!visit[i][j-1] && c[i][j-1] == '@')dfs(i, j-1);if(!visit[i-1][j-1] && c[i-1][j-1] == '@')dfs(i-1, j-1);if(!visit[i-1][j+1] && c[i-1][j+1] == '@')dfs(i-1, j+1);if(!visit[i+1][j-1] && c[i+1][j-1] == '@')dfs(i+1, j-1);if(!visit[i+1][j+1] && c[i+1][j+1] == '@')dfs(i+1, j+1);
}int main()
{
    //freopen("in.txt","r", stdin);while(cin>>m>>n, m!=0){
    for(int i=1;i<=m;i++)for(int j=1;j<=n;j++){
    cin>>c[i][j];visit[i][j] = false;}int ans = 0;for(int i=1;i<=m;i++)for(int j=1;j<=n;j++)if(!visit[i][j] && c[i][j] == '@'){
    ans++;dfs(i, j);}cout<<ans<<endl;}return 0;
}

优化之后:

#include<iostream>
using namespace std;const int M = 105;
const int N = 105;char c[M][N];
bool visit[M][N];
int m, n;int nexts[8][2] = {
    {
    1,0},{
    -1,0},{
    0,-1},{
    0,1},{
    -1,-1},{
    -1,1},{
    1,-1},{
    1,1}};//左右上下,45°方向 void dfs(int x, int y)
{
    if(x<1 || x>m || y<1 || y>n)return;visit[x][y] = true;for(int i=0;i<8;i++){
    int tx = x + nexts[i][0];int ty = y + nexts[i][1];if(!visit[tx][ty] && c[tx][ty] == '@')dfs(tx, ty);}
}int main()
{
    //freopen("in.txt","r", stdin);while(cin>>m>>n, m!=0){
    for(int i=1;i<=m;i++)for(int j=1;j<=n;j++){
    cin>>c[i][j];visit[i][j] = false;}int ans = 0;for(int i=1;i<=m;i++)for(int j=1;j<=n;j++)if(!visit[i][j] && c[i][j] == '@'){
    ans++;dfs(i, j);}cout<<ans<<endl;}return 0;
}