当前位置: 代码迷 >> 综合 >> 杭电oj1312:Red and Black
  详细解决方案

杭电oj1312:Red and Black

热度:61   发布时间:2023-12-28 08:09:33.0

Red and Black

链接
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 33213 Accepted Submission(s): 20143

Problem Description

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can’t move on red tiles, he can move only on black tiles.
Write a program to count the number of black tiles which he can reach by repeating the moves described above.

Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.
There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.
‘.’ - a black tile
‘#’ - a red tile
‘@’ - a man on a black tile(appears exactly once in a data set)

Output

For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).

Sample Input
在这里插入图片描述

Sample Output

45
59
6
13

简单dfs搜索:

#include<iostream>
using namespace std;const int W = 25;
const int H = 25;char map[W][H];
bool visit[W][H];
int w, h;
int ans;//记录走过的黑格子的数量 
int nexts[4][2] = {
    {
    0,1},{
    0,-1},{
    1,0},{
    -1,0}};//四个方向 void dfs(int x, int y)
{
    if(x < 1 || x > w || y < 1 || y > h)return;ans++;visit[x][y] = true;for(int i=0;i<4;i++){
    int tx = x + nexts[i][0];int ty = y + nexts[i][1];if(!visit[tx][ty] && map[tx][ty] == '.')dfs(tx, ty);}
}int main()
{
    //freopen("in.txt","r", stdin);while(cin>>h>>w, w!=0 || h!=0){
    int x, y;for(int i=1;i<=w;i++)for(int j=1;j<=h;j++){
    cin>>map[i][j];visit[i][j] = false;if(map[i][j] == '@'){
    x = i;y = j;}}ans = 0;dfs(x, y);cout<<ans<<endl;}return 0;
}