当前位置: 代码迷 >> 综合 >> 最短路 Floyed 代码实现
  详细解决方案

最短路 Floyed 代码实现

热度:67   发布时间:2023-12-26 13:28:19.0

1. 概述

Floyed 多源最短路,即每个点都为节点,简单的说就是求每对节点之间的最短距离。

基本算法思想:Floyed的核心代码只有如下几行,不断更新从节点i 到 节点 j 的距离,这里的更新条件:“节点i 到 节点k 的距离” + “节点k 到节点j 的距离 ”小于“当前节点i 到节点j 的距离” 。

    for(int k=1; k<=n; k++) {for(int i=1; i<=n; i++) {for(int j=1; j<=n; j++) {int tem = a[i][k]+a[k][j];if(tem<a[i][j] && i!=j) {a[i][j] = tem;}}}}

时间复杂度:O(n^3)。

1.  代码实现

// floyed 代码实现
// 时间复杂度: n^3, n 为 节点数#include <iostream>
using namespace std;const int N = 110;
const int INF = 1000000007;
// 存储图, a[i][j] 为节点i 到 节点j 的距离
int a[N][N];
// p[v][w][u] 为 True, u 是 v到w 最短路径上的节点
bool p[N][N][N];// 仅求出每对节点之间的最短距离,a[i][j] 是节点 i 到 节点j 的最短距离
// n 为节点总数, 编号从 1 开始
void floyed(int n) {for(int k=1; k<=n; k++) {for(int i=1; i<=n; i++) {for(int j=1; j<=n; j++) {int tem = a[i][k]+a[k][j];if(tem<a[i][j] && i!=j) {a[i][j] = tem;}}}}
}// 求出每对节点之间的最短距离和最短距离经过的节点
// p[v][w][u] 为 True, u 是 v到w 最短路径上的节点
void floyed_path(int n) {for(int v=1; v<=n; v++) {for(int w=1; w<=n; w++) {for(int u=0; u<=n; u++) {p[v][w][u] = false;// 点v 和 w 之间可达,可达两点之间就一定有最短路径if(a[v][w] < INF) {p[v][w][v] = true;p[v][w][w] = true;}}}}for(int u=1; u<=n; u++) {for(int v=1; v<=n; v++) {for(int w=1; w<=n; w++) {if(a[v][u]+a[u][w]<a[v][w] && v!=w) {a[v][w] = a[v][u]+a[u][w];for(int i=1; i<=n; i++)p[v][w][i] = p[v][u][i] || p[u][w][i];}}}}
}int main() {int n;cin >> n;for(int i=1; i<=n; i++) {for(int j=1; j<=n; j++) {a[i][j] = INF;}}int x, y, dis;for(int i=1; i<=n; i++) {cin >> x >> y >> dis;// 点x 到 点y 的距离为 disa[x][y] = dis;}floyed(n);return 0;
}

2.  代码验证,poj 1125 Stockbroker Grapevine

题目链接:传送

                                                                            Stockbroker Grapevine

Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 37447   Accepted: 20820

 

Description

Stockbrokers are known to overreact to rumours. You have been contracted to develop a method of spreading disinformation amongst the stockbrokers to give your employer the tactical edge in the stock market. For maximum effect, you have to spread the rumours in the fastest possible way. 

Unfortunately for you, stockbrokers only trust information coming from their "Trusted sources" This means you have to take into account the structure of their contacts when starting a rumour. It takes a certain amount of time for a specific stockbroker to pass the rumour on to each of his colleagues. Your task will be to write a program that tells you which stockbroker to choose as your starting point for the rumour, as well as the time it will take for the rumour to spread throughout the stockbroker community. This duration is measured as the time needed for the last person to receive the information.

Input

Your program will input data for different sets of stockbrokers. Each set starts with a line with the number of stockbrokers. Following this is a line for each stockbroker which contains the number of people who they have contact with, who these people are, and the time taken for them to pass the message to each person. The format of each stockbroker line is as follows: The line starts with the number of contacts (n), followed by n pairs of integers, one pair for each contact. Each pair lists first a number referring to the contact (e.g. a '1' means person number one in the set), followed by the time in minutes taken to pass a message to that person. There are no special punctuation symbols or spacing rules. 

Each person is numbered 1 through to the number of stockbrokers. The time taken to pass the message on will be between 1 and 10 minutes (inclusive), and the number of contacts will range between 0 and one less than the number of stockbrokers. The number of stockbrokers will range from 1 to 100. The input is terminated by a set of stockbrokers containing 0 (zero) people. 

Output

For each set of data, your program must output a single line containing the person who results in the fastest message transmission, and how long before the last person will receive any given message after you give it to this person, measured in integer minutes. 
It is possible that your program will receive a network of connections that excludes some persons, i.e. some people may be unreachable. If your program detects such a broken network, simply output the message "disjoint". Note that the time taken to pass the message from person A to person B is not necessarily the same as the time taken to pass it from B to A, if such transmission is possible at all.

Sample Input

3
2 2 4 3 5
2 1 2 3 6
2 1 2 2 2
5
3 4 4 2 8 5 3
1 5 8
4 1 6 4 10 2 7 5 2
0
2 2 5 1 5
0

Sample Output

3 2
3 10

代码一 , 使用floyed():

#include <iostream>
using namespace std;const int N = 110;
const int INF = 1000000007;
// 存储图, a[i][j] 为节点i 到 节点j 的距离
int a[N][N];
// p[v][w][u] 为 True, u 是 v到w 最短路径上的节点
bool p[N][N][N];// 仅求出每对节点之间的最短距离,a[i][j] 是节点 i 到 节点j 的最短距离
// n 为节点总数, 编号从 1 开始
void floyed(int n) {for(int k=1; k<=n; k++) {for(int i=1; i<=n; i++) {for(int j=1; j<=n; j++) {int tem = a[i][k]+a[k][j];if(tem<a[i][j] && i!=j) {a[i][j] = tem;}}}}
}// 求出每对节点之间的最短距离和最短距离经过的节点
// p[v][w][u] 为 True, u 是 v到w 最短路径上的节点
void floyed_path(int n) {for(int v=1; v<=n; v++) {for(int w=1; w<=n; w++) {for(int u=0; u<=n; u++) {p[v][w][u] = false;// 点v 和 w 之间可达,可达两点之间就一定有最短路径if(a[v][w] < INF) {p[v][w][v] = true;p[v][w][w] = true;}}}}for(int u=1; u<=n; u++) {for(int v=1; v<=n; v++) {for(int w=1; w<=n; w++) {if((a[v][u]+a[u][w])<a[v][w] && v!=w) {a[v][w] = a[v][u]+a[u][w];for(int i=1; i<=n; i++)p[v][w][i] = p[v][u][i] || p[u][w][i];}}}}
}int main() {int n;while(cin >> n) {if(0 == n) break;for(int i=1; i<=n; i++) {for(int j=1; j<=n; j++) {a[i][j] = INF;}}for(int i=1; i<=n; i++) {int num, y, dis;cin >> num;for(int j=1; j<=num; j++) {cin >> y >> dis;a[i][y] = dis;}}floyed(n);int ans = INF, t;for(int i=1; i<=n; i++) {int tem = 0;for(int j=1; j<=n; j++) {if(a[i][j]>tem && i!=j) {tem = a[i][j];}}if(tem < ans) {ans = tem;t = i;}}cout << t << " " << ans << endl;}return 0;
}


代码二,用 floyed_path() 试一下。

#include <iostream>
using namespace std;const int N = 110;
const int INF = 1000000007;
// 存储图, a[i][j] 为节点i 到 节点j 的距离
int a[N][N];
// p[v][w][u] 为 True, u 是 v到w 最短路径上的节点
bool p[N][N][N];// 仅求出每对节点之间的最短距离,a[i][j] 是节点 i 到 节点j 的最短距离
// n 为节点总数, 编号从 1 开始
void floyed(int n) {for(int k=1; k<=n; k++) {for(int i=1; i<=n; i++) {for(int j=1; j<=n; j++) {int tem = a[i][k]+a[k][j];if(tem<a[i][j] && i!=j) {a[i][j] = tem;}}}}
}// 求出每对节点之间的最短距离和最短距离经过的节点
// p[v][w][u] 为 True, u 是 v到w 最短路径上的节点
void floyed_path(int n) {for(int v=1; v<=n; v++) {for(int w=1; w<=n; w++) {for(int u=0; u<=n; u++) {p[v][w][u] = false;// 点v 和 w 之间可达,可达两点之间就一定有最短路径if(a[v][w] < INF) {p[v][w][v] = true;p[v][w][w] = true;}}}}for(int u=1; u<=n; u++) {for(int v=1; v<=n; v++) {for(int w=1; w<=n; w++) {if((a[v][u]+a[u][w])<a[v][w] && v!=w) {a[v][w] = a[v][u]+a[u][w];for(int i=1; i<=n; i++)p[v][w][i] = p[v][u][i] || p[u][w][i];}}}}
}int main() {int n;while(cin >> n) {if(0 == n) break;for(int i=1; i<=n; i++) {for(int j=1; j<=n; j++) {a[i][j] = INF;}}for(int i=1; i<=n; i++) {int num, y, dis;cin >> num;for(int j=1; j<=num; j++) {cin >> y >> dis;a[i][y] = dis;}}floyed_path(n);int ans = INF, t;for(int i=1; i<=n; i++) {int tem = 0;for(int j=1; j<=n; j++) {if(a[i][j]>tem && i!=j) {tem = a[i][j];}}if(tem < ans) {ans = tem;t = i;}}cout << t << " " << ans << endl;}return 0;
}