当前位置: 代码迷 >> 综合 >> 1251 统计难题 (字典树)
  详细解决方案

1251 统计难题 (字典树)

热度:58   发布时间:2023-12-26 13:19:43.0

Problem Description

Ignatius最近遇到一个难题,老师交给他很多单词(只有小写字母组成,不会有重复的单词出现),现在老师要他统计出以某个字符串为前缀的单词数量(单词本身也是自己的前缀).

Input

输入数据的第一部分是一张单词表,每行一个单词,单词的长度不超过10,它们代表的是老师交给Ignatius统计的单词,一个空行代表单词表的结束.第二部分是一连串的提问,每行一个提问,每个提问都是一个字符串.

注意:本题只有一组测试数据,处理到文件结束.

Output

对于每个提问,给出以该字符串为前缀的单词的数量.

Sample Input

banana 
band 
bee 
absolute 
acm ba 
b 
band 
abc

Sample Output

 

2 3 1 0

思路:字典树。

// 字典树
// T[1] 为根节点#include <stdio.h>
#include <string.h>
typedef struct word
{bool isword;int child[26], cnt;
} W;
W T[1000100];
int ans, L=1;
char word[11];void Ins(char *a, int k, int idx)
// 将单词 a 插入字典树中
{if(!a[k])return ;if(T[idx].child[a[k]-'a'] > 0)// 如果这个前缀已经出现过{T[T[idx].child[a[k]-'a']].cnt++;Ins(a, k+1, T[idx].child[a[k]-'a']);}else{T[idx].child[a[k]-'a'] = ++L;T[L].cnt ++;Ins(a, k+1, L);}
}
void Search(char *a,int k,int idx)
{if(!a[k]){printf("%d\n",T[idx].cnt);return ;}if(T[idx].child[a[k]-'a'] == 0){printf("0\n");return ;}Search(a,k+1,T[idx].child[a[k]-'a']);
}
int main()
{L = 1;/*	for(int i=1; i<=100000; i++) {T[i].cnt = 0;memset(T[i].child, 0, sizeof(T[i].child));}*/while(gets(word)&&word[0])Ins(word,0,1);while(gets(word)){Search(word,0,1);}return 0;
}/* EG:
banana
band
bee
absolute
acmba 2
b 3
band 1
abc 0
*/

 

  相关解决方案