当前位置: 代码迷 >> 综合 >> Hdu oj 1285 确定比赛名次(拓扑排序)
  详细解决方案

Hdu oj 1285 确定比赛名次(拓扑排序)

热度:21   发布时间:2023-12-22 04:50:02.0

确定比赛名次

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 20377    Accepted Submission(s): 8191


Problem Description
有N个比赛队(1<=N<=500),编号依次为1,2,3,。。。。,N进行比赛,比赛结束后,裁判委员会要将所有参赛队伍从前往后依次排名,但现在裁判委员会不能直接获得每个队的比赛成绩,只知道每场比赛的结果,即P1赢P2,用P1,P2表示,排名时P1在P2之前。现在请你编程序确定排名。

Input
输入有若干组,每组中的第一行为二个数N(1<=N<=500),M;其中N表示队伍的个数,M表示接着有M行的输入数据。接下来的M行数据中,每行也有两个整数P1,P2表示即P1队赢了P2队。

Output
给出一个符合要求的排名。输出时队伍号之间有空格,最后一名后面没有空格。

其他说明:符合条件的排名可能不是唯一的,此时要求输出时编号小的队伍在前;输入数据保证是正确的,即输入数据确保一定能有一个符合要求的排名。

Sample Input
  
   
4 3 1 2 2 3 4 3

Sample Output
  
   
1 2 4 3

Author
SmallBeer(CML)

Source
杭电ACM集训队训练赛(VII)
因为这个题特意去学的拓扑排序,并不难,这题就是纯拓扑排序
#include<cstdio>
#include<iostream>
#include<algorithm>
#include<cstring>
using namespace std;const int maxn = 505;
int a[maxn][maxn];
int degree[maxn];
int output[maxn];
int n,m;
int x,y;
int cnt;void Toposort()
{while(true){int pos = 1;while(degree[pos]){pos++;if(degree[pos] == 0 || pos >n)break;}degree[pos] = -1;output[cnt++] = pos;if(cnt == n)break;for(int i=1;i<=n;i++){if(a[pos][i] > 0){degree[i]--;a[pos][i] = -1;}}}
}
int main()
{while(~scanf("%d%d",&n,&m)){memset(a,0,sizeof(a));memset(degree,0,sizeof(degree));for(int i=0;i<m;i++){scanf("%d%d",&x,&y);if(a[x][y] == 0){degree[y]++;a[x][y]++;}}cnt = 0;Toposort();for(int i=0;i<n;i++){printf("%d",output[i]);if(i != n-1)printf(" ");}printf("\n");}return 0;
}