当前位置: 代码迷 >> 综合 >> old bill 枚举
  详细解决方案

old bill 枚举

热度:23   发布时间:2023-12-20 23:40:23.0

题目描述:
Among grandfather’s papers a bill was found.
72 turkeys $679
The first and the last digits of the number that obviously represented the total price of those turkeys are replaced here by blanks (denoted _), for they are faded and are illegible. What are the two faded digits and what was the price of one turkey?
We want to write a program that solves a general version of the above problem.
N turkeys $XYZ
The total number of turkeys, N, is between 1 and 99, including both. The total price originally consisted of five digits, but we can see only the three digits in the middle. We assume that the first digit is nonzero, that the price of one turkeys is an integer number of dollars, and that all the
turkeys cost the same price.
Given N, X, Y, and Z, write a program that guesses the two faded digits and the original price. In case that there is more than one candidate for the original price, the output should be the most expensive one. That is, the program is to report the two faded digits and the maximum price per turkey for the turkeys.

输入:
The first line of the input file contains an integer N (0<N<100), which represents the number of turkeys. In the following line, there are the three decimal digits X, Y, and Z., separated by a space, of the original price $XYZ.

输出:
For each case, output the two faded digits and the maximum price per turkey for the turkeys.

样例输入:
72
6 7 9
5
2 3 7
78
0 0 5
样例输出:
3 2 511
9 5 18475
0
来源:
2007年上海交通大学计算机研究生机试真题

思路:该问题即寻找最大单价 使用枚举的方法,9*10的复杂度

#include<iostream>
using namespace std;
int main() {
    int n;while (cin >> n) {
    int x, y, z;cin >> x >> y >> z;int now;int flag = 0;//用于跳出循环以及判断是否找到了有效输出int base = z * 10 + y * 100 + x * 1000;for (int i = 9; i > 0; i--) {
    for (int j = 9; j >= 0; j--) {
    now = i * 10000 + base + j;if (now % n == 0) {
     cout << i << " " << j << " " << now / n << endl;flag = 1;break;}}if (flag == 1) {
     break; }}if (flag == 0) cout << 0 << endl;}
}