当前位置: 代码迷 >> 综合 >> poj 3253 Fence Repair (STL优先队列)
  详细解决方案

poj 3253 Fence Repair (STL优先队列)

热度:42   发布时间:2023-12-20 23:39:02.0

Description
Farmer John wants to repair a small length of the fence around the pasture. He measures the fence and finds that he needs N (1 ≤ N ≤ 20,000) planks of wood, each having some integer length Li (1 ≤ Li ≤ 50,000) units. He then purchases a single long board just long enough to saw into the N planks (i.e., whose length is the sum of the lengths Li). FJ is ignoring the “kerf”, the extra length lost to sawdust when a sawcut is made; you should ignore it, too.
FJ sadly realizes that he doesn’t own a saw with which to cut the wood, so he mosies over to Farmer Don’s Farm with this long board and politely asks if he may borrow a saw.
Farmer Don, a closet capitalist, doesn’t lend FJ a saw but instead offers to charge Farmer John for each of the N-1 cuts in the plank. The charge to cut a piece of wood is exactly equal to its length. Cutting a plank of length 21 costs 21 cents.
Farmer Don then lets Farmer John decide the order and locations to cut the plank. Help Farmer John determine the minimum amount of money he can spend to create the N planks. FJ knows that he can cut the board in various different orders which will result in different charges since the resulting intermediate planks are of different lengths.
Input
Line 1: One integer N, the number of planks
Lines 2…N+1: Each line contains a single integer describing the length of a needed plank
Output
Line 1: One integer: the minimum amount of money he must spend to make N-1 cuts
Sample Input
3
8
5
8
Sample Output
34
Hint
He wants to cut a board of length 21 into pieces of lengths 8, 5, and 8.
The original board measures 8+5+8=21. The first cut will cost 21, and should be used to cut the board into pieces measuring 13 and 8. The second cut will cost 13, and should be used to cut the 13 into 8 and 5. This would cost 21+13=34. If the 21 was cut into 16 and 5 instead, the second cut would cost 16 for a total of 37 (which is more than 34).

解题思路:
(1)题意:有一块长木板,要锯n-1次,锯成n块。每次切断木板时,需要的开销为这块木板的长度,求出按照目标要求将木板切割完最小的开销。
(2)例:锯2次,锯成3块,长度为8,5,8。将长为21(8+5+8=21)的木板切成长为13和8的木板,此时开销为21。再将长为13的木板切成5和8的木板时,开销为13。于是总开销为34.
(3)抽象:看做哈夫曼树的求解过程。
(4)方法:在集合中找出两块长度最短的木板,合并加入到集合中,重复过程,直到集合中只剩下一个元素。
(5)注意:求和时,使用long long 类型

使用STL的优先队列,priority_queue,非常方便简单。
方法1:

//构建小顶堆 
#include <iostream>
#include <cstring>
#include <cstdio>
#include <queue>
//在我的vs2015中需要包含该头文件才能正常编译运行,否则无法识别greater函数
#include<functional>
using namespace std;
int main()
{
    int n;while (cin >> n){
    priority_queue<int, vector<int>, greater<int> > qu;for (int i = 1; i <= n; i++){
    long long x;cin >> x;qu.push(x);}long long res = 0, a = 0, b = 0;while (qu.size() > 1){
    a = qu.top();qu.pop();b = qu.top();qu.pop();res += a + b;qu.push(a + b);}cout << res << endl;}//system("pause");return 0;
}

方法2:学习一下在结构体中重载运算符的方法O(∩_∩)O

#include <iostream>
#include <queue>
//#include<functional>
using namespace std;
struct node {
    long long x;bool operator < (const node &a) const{
    return x > a.x;}
};
int main()
{
    int n;while (cin >> n){
    //priority_queue<int, vector<int>, greater<int> > qu;priority_queue<node> qu;for (int i = 1; i <= n; i++){
    node x;cin >> x.x;qu.push(x);}node a, b;a.x = 0; b.x = 0;long long ans=0;while (qu.size() > 1){
    a = qu.top();qu.pop();b = qu.top();qu.pop();ans += a.x + b.x;a.x = a.x + b.x;qu.push(a);}cout << ans << endl;}//system("pause");return 0;
}
  相关解决方案