当前位置: 代码迷 >> 综合 >> POJ 3069 Saruman's Army(贪心) 解题报告
  详细解决方案

POJ 3069 Saruman's Army(贪心) 解题报告

热度:28   发布时间:2023-12-20 23:36:47.0

题目描述

Input
The input test file will contain multiple cases. Each test case begins with a single line containing an integer R, the maximum effective range of all palantirs (where 0 ≤ R ≤ 1000), and an integer n, the number of troops in Saruman’s army (where 1 ≤ n ≤ 1000). The next line contains n integers, indicating the positions x1, …, xn of each troop (where 0 ≤ xi ≤ 1000). The end-of-file is marked by a test case with R = n = ?1.
Output
For each test case, print a single integer indicating the minimum number of palantirs needed.
Sample Input
0 3
10 20 20
10 7
70 30 1 7 15 20 50
-1 -1
Sample Output
2
4
Hint
In the first test case, Saruman may place a palantir at positions 10 and 20. Here, note that a single palantir with range 0 can cover both of the troops at position 20.
In the second test case, Saruman can place palantirs at position 7 (covering troops at 1, 7, and 15), position 20 (covering positions 20 and 30), position 50, and position 70. Here, note that palantirs must be distributed among troops and are not allowed to “free float.” Thus, Saruman cannot place a palantir at position 60 to cover the troops at positions 50 and 70.

题目大意:在一条直线上,有n个点。从这n个点中选择若干个点加上标记。对于直线上的每一个点,其距离为R以内(包括距离R)的区域里必须有一个被标记的点,求出应该标记的点的最小数目。

解题思路:贪心算法,每次都从最左边的点开始考虑。对于这个点,到距其R以内(包括R)的区域内必须要有带标记的点。此点位于最左侧,显然带标记的点一定在其右侧(包括该点本身)。给从最左边开始,距离为R以内的最远的点加上标记,尽可能的覆盖更靠右边的点。对于添加了标记的点右侧相距超过R的下一个点,采用同样的方法找到R距离以内最远的点添加标记。在所有点都被覆盖之前不断重复这一过程。
在这里插入图片描述

#include<iostream>
#include<algorithm>
using namespace std;
int r;
int num[1001];
int main() {
    int n, ans;int left;while (cin >> r >> n) {
    ans = 0; left = 1;//初始化if (r == -1 && n == -1) {
     break; }for (int i = 1; i <= n; i++) {
    cin >> num[i];}sort(num + 1, num + 1 + n);while (left <= n) {
    //left是没有被覆盖的最左边的点int i = left +1;//一直前进直到离left点距离大于rwhile (i <= n && num[i] - num[left] <= r ) i++;/*i是第一个距离left的位置距离超出r的点因此i-1处要做上标记*/int j = i - 1;//一直前进直到超出i-1处的覆盖范围while (i <= n && num[i] - num[j] <= r) i++;left = i;ans++;}cout << ans << endl;}//system("pause");return 0;
}