当前位置: 代码迷 >> 综合 >> POJ 3734 Blocks 矩阵快速幂
  详细解决方案

POJ 3734 Blocks 矩阵快速幂

热度:59   发布时间:2023-12-20 23:31:12.0

题目链接

Description
Panda has received an assignment of painting a line of blocks. Since Panda is such an intelligent boy, he starts to think of a math problem of painting. Suppose there are N blocks in a line and each block can be paint red, blue, green or yellow. For some myterious reasons, Panda want both the number of red blocks and green blocks to be even numbers. Under such conditions, Panda wants to know the number of different ways to paint these blocks.
Input
The first line of the input contains an integer T(1≤T≤100), the number of test cases. Each of the next T lines contains an integer N(1≤N≤10^9) indicating the number of blocks.
Output
For each test cases, output the number of ways to paint the blocks in a single line. Since the answer may be quite large, you have to module it by 10007.
Sample Input
2
1
2
Sample Output
2
6

题目大意:
给定N个方块排成一列。现要用红黄蓝绿四种颜色的油漆对方块进行染色,每个方块只能染成一种颜色。求红色方块和绿色方块的个数同时为偶数时的染色方案个数,输出模10007后的结果。

解题思路:
矩阵快速幂
下面是参考了《挑战程序设计》这本书得出的题目分析:
让我们试着从最左边开始染色,设染到第i个方块为止,红绿都是偶数的方案数为ai ,红绿只有一个是偶数的方案数为bi ,红绿都是奇数的方案数为ci
这样,染到第i+1个方块时,有以下递推式:

a i+1 = 2*a i + b i
b i+1 = 2*a i + 2*b i + 2*c i
c i+1 = b i + 2*c i

将上述递推式用矩阵表示如下:
[ a i + 1 b i + 1 c i + 1 ] = [ 2 1 0 2 2 2 0 1 2 ] [ a i b i c i ] \left[ \begin{matrix} a_{i+1} \\ b_{i+1} \\ c_{i+1} \end{matrix} \right] = \left[ \begin{matrix} 2 & 1 & 0 \\ 2 & 2 & 2 \\ 0 & 1 & 2 \end{matrix} \right] \left[ \begin{matrix} a_{i}\\ b_{i}\\ c_{i} \end{matrix} \right] ???ai+1?bi+1?ci+1?????=???220?121?022???????ai?bi?ci?????
由题意得,a1=2,b1=2,c1=0 ,因此可得:
[ a i b i c i ] = [ 2 1 0 2 2 2 0 1 2 ] i ? 1 [ a 1 b 1 c 1 ] = [ 2 1 0 2 2 2 0 1 2 ] i ? 1 [ 2 2 0 ] \left[ \begin{matrix} a_{i} \\ b_{i} \\ c_{i} \end{matrix} \right] = \left[ \begin{matrix} 2 & 1 & 0 \\ 2 & 2 & 2 \\ 0 & 1 & 2 \end{matrix} \right]^{i-1} \left[ \begin{matrix} a_{1}\\ b_{1}\\ c_{1} \end{matrix} \right] = \left[ \begin{matrix} 2 & 1 & 0 \\ 2 & 2 & 2 \\ 0 & 1 & 2 \end{matrix} \right]^{i-1} \left[ \begin{matrix} 2\\ 2\\ 0 \end{matrix} \right] ???ai?bi?ci?????=???220?121?022????i?1???a1?b1?c1?????=???220?121?022????i?1???220????

AC代码:

#include<iostream>
#include<stdio.h>
#include<vector>
using namespace std;
typedef long long ll;
typedef vector<int> vec;
typedef vector<vec> mat;
const int M = 10007;
mat mul(mat a, mat b) {
    mat c(a.size(), vec(b[0].size()));//a的行数 b的列数for (int i = 0; i < a.size(); i++) {
    for (int k = 0; k < b.size() ; k++) {
    for (int j = 0; j < b[0].size(); j++) {
    c[i][j] = (c[i][j] + a[i][k] * b[k][j]) % M;}}}return c;
}
mat mod_pow(mat a, ll n) {
    mat b(a.size(), vec(a[0].size()));for (int i = 0; i < a.size(); i++) {
    b[i][i] = 1;}while (n > 0) {
    if (n & 1) b = mul(b, a);a = mul(a, a);n >>= 1;}return b;
}
int main() {
    int t; ll n;scanf("%d", &t);while (t--) {
    scanf("%lld", &n);mat a(3, vec(3));a[0][0] = 2; a[0][1] = 1; a[0][2] = 0;a[1][0] = 2; a[1][1] = 2; a[1][2] = 2;a[2][0] = 0; a[2][1] = 1; a[2][2] = 2;a = mod_pow(a, n - 1);ll ans = 0;ans += 2 * (a[0][0] + a[0][1]) % M;printf("%lld\n", ans);}
}
  相关解决方案