当前位置: 代码迷 >> 综合 >> hdoj Color the ball
  详细解决方案

hdoj Color the ball

热度:24   发布时间:2023-12-17 08:55:32.0

Color the ball

Time Limit: 9000/3000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 11231    Accepted Submission(s): 5595


Problem Description
N个气球排成一排,从左到右依次编号为1,2,3....N.每次给定2个整数a b(a <= b),lele便为骑上他的“小飞鸽"牌电动车从气球a开始到气球b依次给每个气球涂一次颜色。但是N次以后lele已经忘记了第I个气球已经涂过几次颜色了,你能帮他算出每个气球被涂过几次颜色吗?

Input
每个测试实例第一行为一个整数N,(N <= 100000).接下来的N行,每行包括2个整数a b(1 <= a <= b <= N)。
当N = 0,输入结束。

Output
每个测试实例输出一行,包括N个整数,第I个数代表第I个气球总共被涂色的次数。

Sample Input
  
   
3 1 1 2 2 3 3 3 1 1 1 2 1 3 0

Sample Output
  
   
1 1 1 3 2 1

Author
8600
树状数组区间更新
#include<cstdio>
#include<cstdlib>
#include<cstring>
using namespace std;
const int MAX=100005;
int a[MAX],c[MAX];
int low(int n){
return n&(-n);
}
void add(int p,int q,int n){
while(p<=n){
c[p]+=q;
p+=low(p);
}
}
int sum(int n){
int result=0;
while(n!=0){
result+=c[n];
n-=low(n);
}
return result;
}
int main()
{
int n,m,i,j,a,b;
while(scanf("%d",&n),n){
memset(c,0,sizeof(c));
for(i=1;i<=n;++i){
scanf("%d%d",&a,&b);
add(a,1,n);
add(b+1,-1,n);
}
printf("%d",sum(1));
for(i=2;i<=n;++i){
printf(" %d",sum(i));
}
printf("\n");
}
return 0;
}

  相关解决方案