当前位置: 代码迷 >> 综合 >> hdoj2602 Bone Collector【dp 01背包】
  详细解决方案

hdoj2602 Bone Collector【dp 01背包】

热度:80   发布时间:2023-12-17 08:53:47.0

Bone Collector

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 38890    Accepted Submission(s): 16120


Problem Description
Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?


Input
The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.

Output
One integer per line representing the maximum of the total value (this number will be less than 2 31).

Sample Input
  
   
1 5 10 1 2 3 4 5 5 4 3 2 1

Sample Output
  
   
14
#include<cstdio>
#include<cstdlib>
#include<cstring>
using namespace std;
int dp[1010];
struct Node{int value;int wight;
}A[1010];
int Max(int a,int b)
{return a>b?a:b;
}
int main()
{int t,i,j,n,V;scanf("%d",&t);while(t--){scanf("%d%d",&n,&V);for(i=0;i<n;++i){scanf("%d",&A[i].value);}for(i=0;i<n;++i){scanf("%d",&A[i].wight);}memset(dp,0,sizeof(dp));for(i=0;i<n;++i){for(j=V;j>=A[i].wight;--j){dp[j]=Max(dp[j],dp[j-A[i].wight]+A[i].value);}}printf("%d\n",dp[V]);}return 0;
}