当前位置: 代码迷 >> 综合 >> POJ1316 Milking Time【dp】
  详细解决方案

POJ1316 Milking Time【dp】

热度:79   发布时间:2023-12-17 08:53:24.0
Milking Time
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 5896   Accepted: 2462

Description

Bessie is such a hard-working cow. In fact, she is so focused on maximizing her productivity that she decides to schedule her next N (1 ≤ N ≤ 1,000,000) hours (conveniently labeled 0..N-1) so that she produces as much milk as possible.

Farmer John has a list of M (1 ≤ M ≤ 1,000) possibly overlapping intervals in which he is available for milking. Each interval i has a starting hour (0 ≤ starting_houriN), an ending hour (starting_houri < ending_houriN), and a corresponding efficiency (1 ≤ efficiencyi ≤ 1,000,000) which indicates how many gallons of milk that he can get out of Bessie in that interval. Farmer John starts and stops milking at the beginning of the starting hour and ending hour, respectively. When being milked, Bessie must be milked through an entire interval.

Even Bessie has her limitations, though. After being milked during any interval, she must rest R (1 ≤ RN) hours before she can start milking again. Given Farmer Johns list of intervals, determine the maximum amount of milk that Bessie can produce in the N hours.

Input

* Line 1: Three space-separated integers: N, M, and R
* Lines 2..M+1: Line i+1 describes FJ's ith milking interval withthree space-separated integers: starting_houri , ending_houri , and efficiencyi

Output

* Line 1: The maximum number of gallons of milk that Bessie can product in the N hours

Sample Input

12 4 2
1 2 8
10 12 19
3 6 24
7 10 31

Sample Output

43
题意给定一个时间间隔N在这个时间间隔内有M段段时间给出这M段时间每段的工作量和开始终止时间求N时间最大工作量每段工作后要休息R(将R算在每个时间段的结尾)
将这M段时间按开始时间从小到大排序dp[i]表示以i时间最大工作量;
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<algorithm>
using namespace std;
struct Node{int start;int end;int efficitive;
}A[1010];
int dp[1010];
bool cmp(Node a,Node b)
{return a.start<b.start;
}
int Max(int a,int b)
{return a>b?a:b;
}
int main()
{int N,M,R,i,j;while(scanf("%d%d%d",&N,&M,&R)!=EOF){for(i=0;i<M;++i){scanf("%d%d%d",&A[i].start,&A[i].end,&A[i].efficitive);A[i].end+=R;}stable_sort(A,A+M,cmp);int count;count=dp[0]=A[0].efficitive;for(i=1;i<M;++i){dp[i]=A[i].efficitive;for(j=i-1;j>=0;--j){if(A[i].start-A[j].end>=0){dp[i]=Max(dp[i],dp[j]+A[i].efficitive);}}count=Max(count,dp[i]);}printf("%d\n",count);}return 0;
}


  相关解决方案